Bug 383211 - Move 32 on 64 para virt guests from tech preview to supported
Move 32 on 64 para virt guests from tech preview to supported
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Burns
Martin Jenner
:
: 428826 (view as bug list)
Depends On: 318891 425411
Blocks: 227614 RHEL5u2_relnotes 448753 460955 RHEL5u4_relnotes
  Show dependency treegraph
 
Reported: 2007-11-14 14:44 EST by Bill Burns
Modified: 2009-10-22 11:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
With resolution of various issues such as: save/restore, live migration and core dumps, Xen based 32 bit paravirtualized guests on x86_64 hosts are no longer classed as a Technology Preview, and are fully supported on Red Hat Enterprise Linux 5.4.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 11:15:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Martin Jenner 2007-12-06 15:45:58 EST
Just to be clear, we are talking para virt guests here. I updated the Summary
line to be a little clearer
Comment 4 Bill Burns 2007-12-10 11:57:11 EST
Upstream patch to fix issue with live migration.

http://xenbits.xensource.com/xen-unstable.hg?rev/46776e65e679
Comment 5 Bill Burns 2007-12-11 09:09:16 EST
Update to required changesets, all based on Xen 3.1.3. Replaces the one in
comment #4 from unstable:
15533: http://xenbits.xensource.com/xen-3.1-testing.hg?rev/b4331a2778bc
15535: http://xenbits.xensource.com/xen-3.1-testing.hg?rev/1177efd2500e
15514: http://xenbits.xensource.com/xen-3.1-testing.hg?rev/bb22138a7689
Comment 6 Bill Burns 2007-12-12 16:06:30 EST
Posted.
Comment 7 Bill Burns 2007-12-17 16:02:34 EST
Moving back to assigned as a blocker bug for this has been found.
Comment 8 Chris Lalancette 2008-01-23 09:26:04 EST
*** Bug 428826 has been marked as a duplicate of this bug. ***
Comment 9 Bill Burns 2008-01-31 14:26:28 EST
Clearing dev ack as it is not clear that this is solvable in RHEL 5.2.
Comment 10 Bill Burns 2008-02-08 11:01:18 EST
This may remain tech preview of RHEL 5.2. Not sure it was noted in RHEL 5.1. But
there needs to be a note on it.
Comment 11 Don Domingo 2008-02-10 17:59:59 EST
added to RHEL5.2 release notes under "Feature Updates => Virtualization:"

<quote>
The following Virtualization updates are also included in this release:
<snip />
        * (x86_64) You can now run 32-bit guests on 64-bit hosts. This
capability is now included as a technology preview.
</quote>

please advise if any further revisions are required. thanks!
Comment 12 Don Domingo 2008-03-09 20:18:39 EDT
revised note (as per BZ#425411):

<quote>
You can now run 32-bit guests on 64-bit hosts. This capability is now included
as a technology preview. Note, that the ability to save, restore, and migrate
32-bit guests on 64-bit hosts is not functional, and as such should not be
attempted.
</quote>

please advise if any further revisions are required. thanks!
Comment 13 Stephen Tweedie 2008-03-10 10:57:30 EDT
Nonono, it MUST specify that this tech-preview status only applies to
paravirtualised guests.  Fully virt 32-on-64 support has been there since GA,
fully supported.
Comment 14 Don Domingo 2008-03-10 19:37:59 EDT
thanks Stephen, edited as: 

<quote>
 You can now run paravirtualized 32-bit guests on 64-bit hosts. This capability
is now included as a technology preview. Note that the ability to save, restore,
and migrate paravirtualized 32-bit guests on 64-bit hosts is not functional, and
as such should not be attempted.
</quote>
Comment 15 RHEL Product and Program Management 2008-03-11 15:37:33 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 16 Don Domingo 2008-04-01 22:13:36 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 17 Bill Burns 2009-06-24 06:55:07 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
With RHEL 5.4 32 bit PV guests on x86_64 move from Tech Preview to supported die to the resolution of issues with save/restore and migrartion.
Comment 19 Bill Burns 2009-06-24 07:16:05 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-With RHEL 5.4 32 bit PV guests on x86_64 move from Tech Preview to supported die to the resolution of issues with save/restore and migrartion.+With RHEL 5.4 32 bit PV guests on x86_64 move from Tech Preview to supported due to the resolution of issues with save/restore and migrartion.
Comment 22 Chris Lalancette 2009-07-17 03:11:26 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-With RHEL 5.4 32 bit PV guests on x86_64 move from Tech Preview to supported due to the resolution of issues with save/restore and migrartion.+With RHEL 5.4 Xen 32 bit paravirtualized guests on x86_64 dom0 will be come fully supported due to the resolution of various issues, including save/restore, live migration, and core-dump.
Comment 23 Ryan Lerch 2009-07-26 20:31:40 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-With RHEL 5.4 Xen 32 bit paravirtualized guests on x86_64 dom0 will be come fully supported due to the resolution of various issues, including save/restore, live migration, and core-dump.+With resolution of various issues such as: save/restore, live migration and core dumps, Xen based 32 bit paravirtualized guests on x86_64 hosts are no longer classed as a Technology Preview, and are fully supported on Red Hat Enterprise Linux 5.4.
Comment 24 Chris Lalancette 2009-10-22 11:15:07 EDT
I guess this bug is no longer needed since 5.4 was released, so closing it as CURRENTRELEASE.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.