Bug 383821 - java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Status: CLOSED DUPLICATE of bug 301691
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 22:36 EST by Michael McLagan
Modified: 2014-06-18 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 10:16:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 11390 None None None Never

  None (edit)
Description Michael McLagan 2007-11-14 22:36:50 EST
Description of problem:

Java apps using AWT crash with summary message above including JDK apps like
jconsole.

Version-Release number of selected component (if applicable):

libX11-1.1.3-4.fc8

How reproducible:

ALWAYS

Steps to Reproduce:
1. install Fedora 8
2. install JDK 6u3
3. run jconsole
  
Actual results:

[mmclagan@titan ~]$ /usr/java/latest/bin/jconsole    
jconsole: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted

Expected results:

Opens the console.

Additional info:

Reverting to libX11-1.0.3-8.fc7.i386.rpm solves the problem.
Also refer to:

   http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

(would be nice if Sun's JAVA bug tracker would be in the external list).
Comment 1 Matěj Cepl 2007-11-15 10:16:03 EST

*** This bug has been marked as a duplicate of 292581 ***
Comment 2 Matěj Cepl 2007-11-15 10:18:01 EST

*** This bug has been marked as a duplicate of 301691 ***

Note You need to log in before you can comment on or make changes to this bug.