Bug 292581 - Sun Java plugin for firefox unable to start with error "xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed."
Sun Java plugin for firefox unable to start with error "xcb_xlib.c:50: xcb_xl...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-16 16:45 EDT by Roman
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 15:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman 2007-09-16 16:45:54 EDT
Description of problem:


Version-Release number of selected component (if applicable):
latest Fedora devel (after yum upgrade)
firefox-2.0.0.6-8.fc8 (also repeated at ver 3.0a7)
jre1.6.0_02 from java.sun.com

How reproducible:
100%

Steps to Reproduce:
1.start firefox from konsole
2.go to http://java.com/en/download/help/testvm.xml (or any other site thet use
java)
3. plugin dont start, at konsole I see this messages:

java_vm: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Could not read ack from child process
Plugin: Java VM process has died.
plugin: java process died due to signal 6
Could not start JavaVM!

VM did not start up properly


  
Actual results:
plugin cant start

Expected results:
working plugin

Additional info:
Comment 1 ritz 2007-09-24 08:37:41 EDT
NOTABUG afaik.

This seems to be a bug with java
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

From Josh Triplett

The following workarounds address this problem:

For sun-java5-bin:
sed -i 's/XINERAMA/FAKEEXTN/g'
/usr/lib/jvm/java-1.5.0-sun-1.5.0.11/jre/lib/i386/xawt/libmawt.so

For sun-java6-bin:
sed -i 's/XINERAMA/FAKEEXTN/g'
/usr/lib/jvm/java-6-sun-1.6.0.00/jre/lib/i386/xawt/libmawt.so

The same fix (applied to the appropriate file) might work for other
proprietary JDKs.
Comment 2 Roman 2007-09-24 15:11:54 EDT
Yes, it fix all problems.
Thank You!
Comment 3 Matěj Cepl 2007-11-15 10:15:46 EST
*** Bug 383331 has been marked as a duplicate of this bug. ***
Comment 4 Matěj Cepl 2007-11-15 10:16:04 EST
*** Bug 383821 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.