Bug 384031 - button background & effects don't follow their arrangement in Nokoda theme
button background & effects don't follow their arrangement in Nokoda theme
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nodoka-theme-gnome (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 00:14 EST by Stefan Plewako
Modified: 2008-04-19 05:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 05:06:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot of a problem in Nokoda theme (7.53 KB, image/png)
2007-11-15 00:14 EST, Stefan Plewako
no flags Details
Proposed solution 1 (21.67 KB, image/png)
2007-11-18 08:05 EST, Martin Sourada
no flags Details
Solution 2 (21.79 KB, image/png)
2007-11-19 04:58 EST, Martin Sourada
no flags Details

  None (edit)
Description Stefan Plewako 2007-11-15 00:14:03 EST
Description of problem:
If you change titlebar button layout (eg to mac alike arrangement) when using
Nokoda Gnome theme, light blue button background will no follow change, instead
it will remain on right side (eg under icon of window menu).

Button hover effect is also lost.

How reproducible: always
Steps to Reproduce:
1. Open Gnome Configuration Editor
2. Find /apps/metacity/general/button_layout
3. Change it to: close,maximize,minimize:menu
Actual results: as in attached screenshot
Expected results: button background & effects will follow their placement
Comment 1 Stefan Plewako 2007-11-15 00:14:04 EST
Created attachment 259471 [details]
A screenshot of a problem in Nokoda theme
Comment 2 Martin Sourada 2007-11-18 08:04:02 EST
Thanks for the report. I am aware of this problem and until now I was unsure as
to how to approach it. The problem arose as a result of the want to have all the
buttons joined. I reworked the metacity to have the buttons together, but not
joined, I'll attach a screenshot of the proposed solution for your considering.
Comment 3 Martin Sourada 2007-11-18 08:05:26 EST
Created attachment 262861 [details]
Proposed solution 1
Comment 4 Stefan Plewako 2007-11-19 03:18:43 EST
As far as I can see there is still one problem, borders inside button block are
two times wider then outside of it.

I'm not familiar with theme creation but this seems to be an affect of using
borders as splitters, right? Would it be possible to eliminate borders from
buttons backgrounds, put button background (gradient) in button image file and
use background to create borders with collapsing margins between buttons (if CSS
like), or some oder trick?

I don't think that it is good idea to break things for most of users. (as in
solution#1)
Comment 5 Martin Sourada 2007-11-19 04:58:26 EST
Created attachment 263371 [details]
Solution 2

There are two basic things how can you do a button layout and both has their
drawbacks:

1. you specify the backgrounds according to position of the button, which is
the original implementation - it however is fixed to the window and leads to
this bug

2. you specify the background for each button, which leads to the problem in
solution#1 - i.e. the borders are for each buttons and that results in the
effect of thicker line between buttons, I tried to get rid of that effect as
much as possible, but it seems quite hard to achieve.

I attach another try, the look is not final, but suggests the way I'd like to
take.
Comment 6 Stefan Plewako 2007-11-19 09:57:14 EST
(In reply to comment #5)
> I attach another try, the look is not final, but suggests the way I'd like to
> take.

I think it is much better one.
Do You plan somehow to draw left border only for the first button on each side?
Comment 7 Stefan Plewako 2008-04-19 05:06:42 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.