Bug 38409 - xauth should be split out into its own package
xauth should be split out into its own package
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
: FutureFeature
: 62426 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 12:52 EDT by Henning Schmiedehausen
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-27 11:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning Schmiedehausen 2001-04-30 12:52:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-1t i686)


After RedHat finally ships an OpenSSH with its products, it is annoying to
install all
the XFree86 packages just to get the sshd calling xauth for X11 display
forwarding. On
a server, it should be enough to install the libs and a RPM which contains
just xauth

This is especially annoying if disk space is tight.

Reproducible: Always
Steps to Reproduce:
rpm -ql XFree86 | grep xauth

Just create a new RPM, e.g. XFree86-xauth from the XFree86 SRPM which
contains
just /usr/X11R6/bin/xauth and its man-page. Make it require XFree86-libs.
Done.
Comment 1 Mike A. Harris 2001-05-01 04:16:22 EDT
I agree that this is annoying, and will do something about it after
looking deeper into the matter.  This has annoyed me since before I worked
here as well.  <grin>  Thanks for pointing out this pet peeve.  I'll try
to roll something into a future release to eliminate the bloatitis.  No doubt
there are other similar issues that might be solveable in a unified way.
Comment 2 Mike A. Harris 2001-05-15 06:56:36 EDT
The problem is not with xauth, it is with the locale data not being in the
libs subpackage.  The locale data is moved from the XFree86 package to the
libs packge now.  Please upgrade to XFree86-4.0.3-15 from:
ftp://people.redhat.com/mharris/testing
Comment 3 Henning Schmiedehausen 2001-05-15 07:38:56 EDT
No, wrong. A program like the sshd needs xauth to set authentication for X
Forwarding.

At the moment, I must install XFree and XFree-libs to get X-Forwarding from SSH.
I just want
to install XFree-libs (which I need anyway) and XFree-xauth.

I built a custom XFree distribution for my internal usage and this split works
fine and is reasonable.
Comment 4 Mike A. Harris 2001-10-04 12:00:22 EDT
After talking with Nalin about this, he says it is a bug in openssh
which is about to be fixed shortly, reassigning.
Comment 5 Mike A. Harris 2001-10-04 12:02:32 EDT
Duh, I just noticed this is fixed in rawhide... closing

fix verified in openssh-2.9p2-5

Comment 6 Henning Schmiedehausen 2001-10-04 13:06:15 EDT
Hm. Is it possible that you didn't understand me?

I have a server. This server hast just one X application for managing one of the
services (let's call it a backup system). I want to do the following thing:

- Log into it with ssh
- the X-Display for the session gets forwarded over the ssh tunnel by enabling
  it with xauth
- start my application (let's call it "ARKEIA" for sake of having a name)

I need for this:

- SSH
- The application
- /usr/X11R6/bin/xauth
- The X Libraries

Why should I install _all_ of the XFree86 including lots of potentially harmful
programs like "pcitweak" or "xvidtune" that will be never ever used on this
server if all I need is

- SSH
- The Application
- XFree86-libs
- XFree86-xauth with just one lone binary

So what has all of this to do with "a bug fix in rawhide"?

It seems to me that you don't understand the problem at first.
Comment 7 Harri Haataja 2002-05-27 11:19:36 EDT
XF4 will also require you to install Mesa or Glide3 and several fontsets, xfs...

.. all just to get (for example) ssh -f -X headlesserver xload
Comment 8 Mike A. Harris 2002-05-29 23:00:45 EDT
Just reread the whole report, and indeed at first I did misunderstand the
problem.  My initial prognosis was indeed incorrect at the time (concerning
locale data).  The problem is what you describe, and could be solved by
creating a separate xauth package like you suggest, or by making openssl
not require xauth.  I presumed that the latter was done when the bug was
closed as confirmed.  I do agree the better solution is to have a
separate xauth package however, and as such I have just done so.

XFree86-xauth will appear in rawhide soon.
Comment 9 Mike A. Harris 2002-05-29 23:09:12 EDT
*** Bug 62426 has been marked as a duplicate of this bug. ***
Comment 10 Henning Schmiedehausen 2002-05-30 05:43:00 EDT
Thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.