Bug 62426 - RFE: split xauth into separate package for use on headless systems
Summary: RFE: split xauth into separate package for use on headless systems
Status: CLOSED DUPLICATE of bug 38409
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: skipjack-beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-31 20:48 UTC by Charles R. Anderson
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 18:21:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles R. Anderson 2002-03-31 20:48:27 UTC
Description of Problem:

On a headless system with no X server, it is possible to run X clients
that are displayed remotely (e.g. over an ssh connection) with a minimal
installation of packages (XFree86-libs, freetype, gtk, etc) on the headless
system.  However, the 30MB XFree86 package itself is still required since the
xauth binary is needed.  This also pulls in various other dependencies which
XFree86 requires.  Would it be possible to split xauth and a minimal compliment
of other files into a separate XFree86-utils package for use on headless systems?
This could include most of what is in /usr/X11R6/bin in the current XFree86 package.

Version-Release number of selected component (if applicable):

4.2.0-6.47

Comment 1 Mike A. Harris 2002-04-01 18:21:34 UTC
This is already an RFE somewhere...  I'll leave it open until I find
the duplicate.  I do plan on adding this enhancement sometime, but it
got overlooked this devel cycle...  :o/



Comment 2 Mike A. Harris 2002-05-30 03:09:18 UTC
Done in RAWHIDE now.  Will appear shortly.

*** This bug has been marked as a duplicate of 38409 ***


Note You need to log in before you can comment on or make changes to this bug.