Bug 385281 - Loader Received SIGSEGV!
Loader Received SIGSEGV!
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 13:59 EST by Srikanth Konjarla
Modified: 2008-01-10 11:53 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 11:53:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Srikanth Konjarla 2007-11-15 13:59:15 EST
Description of problem:


Version-Release number of selected component (if applicable):
Fedora 8 Installer

How reproducible:


Steps to Reproduce:
1. Boot from the DVD/LiveCD/HardDisk to install fedora8 on the laptop (Averatec
7170-EC1)
2.
3.
  
Actual results:
Loader Received SIGSEGV! and installer crashes.

Expected results:


Additional info:
The laptop information can be found at
http://smolt.fedoraproject.org/show_all?UUID=8abc1e5c-e0d4-4570-b527-0f07aca66cfc

FWIW, there were no issues with installing Fedora7 (currently fedora7 is running
on this laptop). I have tried again with Fedora7 installer and it works just fine.
Comment 1 Chris Lumens 2007-11-15 14:44:14 EST
Please attach the traceback you are seeing to this bug report.
Comment 2 Srikanth Konjarla 2007-11-15 14:59:31 EST
Here it is. Please note that i have to type manually by looking at the screen of
the laptop that i am attempting to install F8.

loader received SIGSEGV! Backtrace:
[0x804a030]
[0x110420]
[0x816b442]
[0x81697a5]
[0x805c1b0]
[0x804b207]
[0x8175004]
[0x8048151]
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...

(In reply to comment #1)
> Please attach the traceback you are seeing to this bug report.

(In reply to comment #1)
> Please attach the traceback you are seeing to this bug report.

Comment 3 Chris Lumens 2007-11-15 16:23:43 EST
For our future reference:

clumens@exeter:/usr/lib/debug/usr/lib/anaconda-runtime/loader$ eu-addr2line -e
loader.debug 
0x816b442
??:0
0x81697a5
??:0
0x805c1b0
/usr/src/debug/anaconda-11.3.0.50/loader2/hardware.c:76
0x804b207
/usr/src/debug/anaconda-11.3.0.50/loader2/loader.c:487
0x8175004
/usr/src/debug/anaconda-11.3.0.50/stubs/unicode-lite.c:28
0x8048151
??:0
Comment 4 tswan 2007-12-04 13:14:15 EST
There is also a SIGABRT issued as well.  See comments from Bug 375171
https://bugzilla.redhat.com/show_bug.cgi?id=375171#c2.  Perhaps there are
several bugs that should be consolidated to remove duplicates: 375171, 352861
just to point out a few.
Comment 5 Chris Lumens 2008-01-10 11:53:25 EST
This should be fixed in rawhide.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.