Bug 385461 - Broken playback over XVideo extension
Broken playback over XVideo extension
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libXv (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 15:07 EST by Zdenek Kabelac
Modified: 2014-06-18 05:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-drv-i810-2.2.1-20.fc9.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 12:10:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (5.06 KB, application/x-bzip)
2007-11-15 15:07 EST, Zdenek Kabelac
no flags Details
bunzipped2 Xorg.0.log (22.22 KB, text/plain)
2007-11-20 05:14 EST, Matěj Cepl
no flags Details
my own Xorg.0.log (197.83 KB, text/plain)
2007-11-20 05:27 EST, Matěj Cepl
no flags Details
Xorg configuration file (1.74 KB, application/octet-stream)
2007-11-20 05:50 EST, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2007-11-15 15:07:16 EST
Description of problem:

Current version of driver & xorg xserver has very low usability - playback over
xvideo extension is not possible - also gl surface with mplayer locks the machine.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.1.99-1.fc9
xorg-x11-server-Xorg-1.4.99.1-0.10.fc9

How reproducible:
run mplayer -vo xv

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Kabelac 2007-11-15 15:07:16 EST
Created attachment 260351 [details]
Xorg log
Comment 2 Matěj Cepl 2007-11-19 11:04:07 EST

*** This bug has been marked as a duplicate of 200270 ***
Comment 3 Matěj Cepl 2007-11-20 05:14:53 EST
Created attachment 264691 [details]
bunzipped2 Xorg.0.log

please, don't compress the stuff -- it is harder to work with it.
Comment 4 Matěj Cepl 2007-11-20 05:26:35 EST
Can fully reproduce here with ATI Technologies Inc RV380 [Radeon X600].
Comment 5 Matěj Cepl 2007-11-20 05:27:11 EST
Created attachment 264721 [details]
my own Xorg.0.log
Comment 6 Zdenek Kabelac 2007-11-20 05:50:04 EST
Created attachment 264731 [details]
Xorg configuration file

Just for the case it would be contain anything useful I'm attaching also my
configuration for Xorg.
Comment 7 Zdenek Kabelac 2007-11-20 08:18:03 EST
As Matej suggested - I've tested the video playback with Totem &
gstreamer-properties Xv settings and this seems to be working properly. I'll do
more tests later with compiled players (mplayer/avifile) by myself to give more
comments. (As my Xv problem might be possibly some issue of mplayer rpm)

Anyway still applies my problem with Xorg crash while I've tried to -vo gl
surface and mplayer.
Comment 8 Zdenek Kabelac 2007-11-21 06:15:12 EST
I've checked compilation of mplayer from SVN - and even this fresh build
couldn't open Xv rendering - on the other hand - rendering via SDL Xv  seems to
work well. Unfortunately I cannot test avifile as the Qt3 seems to be broken at
this moment.

However - the last commit to Xv output in mplayer is dated 28.Aug and that was
even some minor cosmetic header file change - so I'm not sure, if it's the real
bug of mplayer - or something changed in the Xv interface and requires
modification in the mplayer's code.
Comment 9 Matěj Cepl 2007-11-21 07:18:30 EST
OK, so the conclusion is that there are two issue we should deal with (sorry,
mplayer is off-topic in this bugzilla):

a) using gl video crashes X server,
b) my problem with video being black in totem

Do you see anything else? I will probably split my bug into the separate one.
Comment 10 Zdenek Kabelac 2007-11-21 07:43:11 EST
Adding more details - I'm running default metacity window manager and I'm not
using compiz or any other 3D application (at least none I would know about)
Comment 11 Zdenek Kabelac 2008-04-09 11:15:01 EDT
Update - with current version of Xorg 

xorg-x11-drv-i810-2.2.1-20.fc9.x86_64

the xv rendering surface works ok in mplayer - the bug could be probably closed.

Note You need to log in before you can comment on or make changes to this bug.