Bug 38551 - Internal error in collect_expansion, at tradcpp.c:2844
Summary: Internal error in collect_expansion, at tradcpp.c:2844
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: make   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 38549 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-01 14:20 UTC by Frans Nijenhuis
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-01 15:46:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:082 high SHIPPED_LIVE New version of GCC 2.96-RH available fixing several bugs 2001-06-14 04:00:00 UTC

Description Frans Nijenhuis 2001-05-01 14:20:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4 i686; en-US; 0.8.1) Gecko/20010425


When running "make Makefiles" which calls imake, I now receive the
following message.This used to run without any problems with RedHat 6.2.

[root@aragorn C++SIM]# make Makefiles
Making Makefiles in ./Include
*command line*:1: Internal error in collect_expansion, at tradcpp.c:2844
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
imake: Exit code 1.
  Stop.


Reproducible: Always
Steps to Reproduce:
1.tar xvzf cppsim_1.7.4.tar.gz
2.cd C++SIM
3../configure
4. make -f MakefileBoot
5. make Makefiles
	

Actual Results:  step 5. exits with the internal error

Expected Results:  Step 5. should have produced the makefiles in each
subdirectory

the make Makefiles calls the "imake" command. Apparently, this commands
fails (don't know which *.rpm, so selected make).

Comment 1 Jakub Jelinek 2001-05-01 15:40:24 UTC
*** Bug 38549 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Jelinek 2001-05-01 15:46:24 UTC
I've just fixed this in
http://gcc.gnu.org/ml/gcc-patches/2001-05/msg00019.html
and will include it into gcc-2.96-83 rpm.


Note You need to log in before you can comment on or make changes to this bug.