Bug 304021 - java-1.6.0-openjdk-plugin has no support for Java-to-JavaScript bridge
java-1.6.0-openjdk-plugin has no support for Java-to-JavaScript bridge
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
: 251829 420781 428503 429191 440589 443274 449959 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 16:48 EDT by Thomas Fitzsimmons
Modified: 2009-06-27 11:45 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 16:37:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Fitzsimmons 2007-09-24 16:48:45 EDT
Applets that require Java-to-JavaScript or JavaScript-to-Java communication will
not work with java-1.7.0-icedtea-plugin.
Comment 1 Lillian Angel 2007-11-22 10:24:48 EST
*** Bug 375161 has been marked as a duplicate of this bug. ***
Comment 2 Lillian Angel 2007-12-12 13:30:43 EST
*** Bug 420781 has been marked as a duplicate of this bug. ***
Comment 3 Lillian Angel 2008-01-14 10:47:32 EST
*** Bug 428503 has been marked as a duplicate of this bug. ***
Comment 4 Lillian Angel 2008-01-18 13:21:19 EST
*** Bug 429191 has been marked as a duplicate of this bug. ***
Comment 5 Steve Fraser 2008-01-21 16:11:17 EST
Can we have the severity increased? This is a pretty big feature to have not
working. I for one use webex at work.

Thanks
Steve
Comment 6 Lillian Angel 2008-02-11 10:15:05 EST
*** Bug 432184 has been marked as a duplicate of this bug. ***
Comment 7 Lillian Angel 2008-02-11 13:13:30 EST
*** Bug 432183 has been marked as a duplicate of this bug. ***
Comment 8 Lillian Angel 2008-02-11 13:22:28 EST
(In reply to comment #5)
> Can we have the severity increased? This is a pretty big feature to have not
> working. I for one use webex at work.
> 
> Thanks
> Steve

Tom Fitzsimmons is work on this. It is a big feature, and will take some more time.

Comment 9 Samuel Sieb 2008-03-13 12:18:56 EDT
Can you please explain why the package name was changed?  Is that what the
package is going to be called?  Even if that's the case, that's going to make
this bug harder to find.
Comment 10 Thomas Fitzsimmons 2008-03-13 12:42:31 EDT
(In reply to comment #9)
> Can you please explain why the package name was changed?

See bug 433070 and the Fedora 9 release notes[1] for the name change reasoning.

> Is that what the
> package is going to be called?  Even if that's the case, that's going to make
> this bug harder to find.

How so?

1. http://fedoraproject.org/wiki/Docs/Beats/Java
Comment 11 Samuel Sieb 2008-03-13 14:45:05 EDT
I'm just thinking that anyone using F8 that's looking for this bug will be
searching under "icedtea", not "openjdk".
Comment 12 Thomas Fitzsimmons 2008-04-02 17:03:42 EDT
*** Bug 251829 has been marked as a duplicate of this bug. ***
Comment 13 Lillian Angel 2008-04-04 16:33:58 EDT
*** Bug 440589 has been marked as a duplicate of this bug. ***
Comment 14 Lillian Angel 2008-04-21 08:31:38 EDT
*** Bug 443274 has been marked as a duplicate of this bug. ***
Comment 15 Bug Zapper 2008-05-13 23:16:20 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Lillian Angel 2008-06-19 11:16:46 EDT
*** Bug 449959 has been marked as a duplicate of this bug. ***
Comment 17 Jason Guiditta 2008-06-27 16:59:56 EDT
I know this is described as a big task, but is it getting close?  I really want
to be able to use the openjdk plugin, but need this feature for it to be useful.
 Clearly others think so as well, judging by the number of closed duplicates.
Comment 18 Jason Guiditta 2008-06-30 16:19:55 EDT
On further research, I found what appears to be a patch for this:

http://article.gmane.org/gmane.comp.java.openjdk.distro-packaging.devel/2478

Any chance of this getting into F9 any time soon?

Comment 19 Red Hat Bugzilla 2008-07-24 21:03:57 EDT
Adding patrickm@redhat.com to the cc list as the manager of the disabled user fitzsim@redhat.com who reported this bug
Comment 20 Lillian Angel 2008-08-12 12:49:47 EDT
*** Bug 457522 has been marked as a duplicate of this bug. ***
Comment 21 Mark Wielaard 2008-11-07 04:56:49 EST
I believe this can be CLOSED now that RAWHIDE has the IcedTeaPlugin integrated. Or are there plans to backport that into Fedora 9?
Comment 22 Martin Jürgens 2008-11-07 06:32:00 EST
I'd suggest to keep it opened as otherwise this bug report may not be found by using the search.
Comment 23 Deepak Bhole 2008-11-14 16:37:10 EST
Liveconnect is now supported via the new Java plugin F10/Rawhide. With regards to some of the bugs above:

420781 - Does not appear to be applicable any more

429191 - webex, works, but requires browser to be restart for first use. This is 
         being worked on

432184 - just received a note about this one this morning. Looking into it.

432183 - Does not work with with the Sun plugin either (appears to be bug in 
         applet)

443274 - Has nothing to do with plugin, but is fixed

457522 - Fails, same cause as bug #468490
Comment 24 Marc Schwartz 2008-11-26 08:49:50 EST
There appears to be residual functionality issues with the OpenJDK plug-in in F10.

This may be in part, specific to the R (http://www.r-project.org/) java search applet, but when using the R applet, the following error messages appears in the R Console:

  > ICEDTEAPLUGIN_DEBUG = (null)
  Initializing JVM...
  NOT IMPLEMENTED: virtual nsresult IcedTeaPluginInstance::Start()
  JNLPRuntime already initialized
  NOT IMPLEMENTED: virtual nsresult IcedTeaPluginInstance::Stop()

The R java search applet is started using:

  help.start()

and then selecting the "Search Engine & Keywords" link on the page that comes up in Firefox.

I was only able to get the applet functioning properly using the Sun JRE.  I also reported this on the R-SIG-Fedora list last night after getting F10 installed:

  https://stat.ethz.ch/pipermail/r-sig-fedora/2008-November/000054.html

and this has been an ongoing issue for some time, as noted in the R Admin Manual:

http://cran.r-project.org/doc/manuals/R-admin.html#Enabling-search-in-HTML-help

Thanks.

Note You need to log in before you can comment on or make changes to this bug.