Bug 386651 - crash with planetccrma repository
crash with planetccrma repository
Status: CLOSED DUPLICATE of bug 252136
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 06:41 EST by Paolo Patruno
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 14:20:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash after yum clean all (732.64 KB, application/octet-stream)
2007-11-19 13:45 EST, Paolo Patruno
no flags Details

  None (edit)
Description Paolo Patruno 2007-11-16 06:41:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc7 Firefox/2.0.0.9

Description of problem:
When I work after activation of planet ccrma repository I get this fatal error

Component: pirut
Summary: TB2c94d51b yumRepo.py:175:populate:AttributeError: cacheHandler

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 392, in _setApply
    if len(self.tsInfo) == 0:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 535, in <lambda>
    tsInfo = property(fget=lambda self: self._getTsInfo(),
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 83, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 242, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 175, in populate
    del repo.cacheHandler
AttributeError: cacheHandler

Local variables in innermost frame:
xml: //var/cache/yum/planetccrma/primary.xml.gz
repo_cache_function: <bound method RepodataParserSqlite.getPrimary of <sqlitecachec.RepodataParserSqlite instance at 0xa5dc34c>>
mymdtype: primary
mydbtype: primary_db
self: <yum.sqlitesack.YumSqlitePackageSack object at 0xff19b8c>
repo_get_function: <bound method YumRepository.getPrimaryXML of <yum.yumRepo.YumRepository object at 0x8648e4c>>
ctype: sha
mdtype: metadata
repo: planetccrma
item: metadata
callback: None
xmldata: <yum.repoMDObject.RepoData instance at 0xfe402cc>
csum: 5151fc143b5090830a17fa14b075e1d40f8d3936
data: ['metadata']
cacheonly: 0
db_fn: None


Version-Release number of selected component (if applicable):
pirut-1.3.23-1.fc7

How reproducible:
Always


Steps to Reproduce:
1.open pirut
2.add ccrma repository
# Planet CCRMA repositories
in /etc/yum.repos.d/planetccrma.repo
[planetccrma]
name=Planet CCRMA 7 - i386
baseurl=http://ccrma.stanford.edu/planetccrma/mirror/fedora/linux/planetccrma/7/i386
enabled = 1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-planetccrma
gpgcheck=1

[planetcore]
name=Planet CCRMA Core 7 - i386
baseurl=http://ccrma.stanford.edu/planetccrma/mirror/fedora/linux/planetcore/7/i386
enabled = 1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-planetccrma
gpgcheck=1

3.browse

Actual Results:
pirut crash


Expected Results:


Additional info:
I get other fatal error with trace if needed
Comment 1 Jeremy Katz 2007-11-16 11:06:41 EST
Can you download the pirut package from updates-testing and see if it helps
  yum --enablerepo=updates-testing update pirut
Comment 2 Paolo Patruno 2007-11-16 17:13:38 EST
I am sorry but I cannot find pirut in updates-testing.
Comment 3 Jeremy Katz 2007-11-19 11:10:45 EST
Whoops, I forgot I had pushed the package to the main updates repo the first of
the week.  And it looks like you already have it installed.

Does this happen reliably?  Can you try doing 'yum clean planetccrma' and see if
it helps?
Comment 4 Paolo Patruno 2007-11-19 13:45:33 EST
Created attachment 263791 [details]
crash after yum clean all
Comment 5 Paolo Patruno 2007-11-19 13:47:44 EST
The problem depends from LANG setting

rpm -q pirut
pirut-1.3.23-1.fc7

yum clean all

echo $LANG
it_IT.UTF-8

pirut
I get the crash documentated in the attachment

if I unset LANG pirut works well !!
Comment 6 Jeremy Katz 2007-11-19 14:20:55 EST

*** This bug has been marked as a duplicate of 252136 ***

Note You need to log in before you can comment on or make changes to this bug.