Bug 38669 - /etc/xinetd.d/*-udp files syntax error on
/etc/xinetd.d/*-udp files syntax error on
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
: 49564 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 19:54 EDT by Dan Anderson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-19 18:46:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Anderson 2001-05-01 19:54:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-CCK-MCD Netscape [en] (X11; U; SunOS 5.8 sun4u)


The following files need to have the trailing "-udp" removed on the service
line.
If not done, you get this message in /var/log/messages if the service is
enabled:

May  1 16:46:37 dan xinetd[20864]: No such internal service: time-udp


Reproducible: Always
Steps to Reproduce:
1. Temporarily enable service (change "yes" to "disable = no" in
/etc/xinetd.d/*-udp files)
2. Restart: /etc/rc.d/init.d/xinetd restart
3. Tail log: tail /var/log/messages

	

Actual Results:  You see error messages: No such internal service: time-udp
. . .
And NO service enabled:

# netstat -a |grep ':time ' 
#

Expected Results:  4. NO error message and the service should be enabled:

# netstat -a |grep ':time ' 
tcp        0      0 *:time                  *:*                    
LISTEN      
udp        0      0 *:time                  *:* 
#
Comment 1 Trond Eivind Glomsrxd 2001-05-03 11:32:41 EDT
Removing the "-udp" suffix confuses other services.
Comment 2 Dan Anderson 2001-05-03 16:09:25 EDT
Let me clarify.  Both udp and tcp services can and do have the same name. Lets
take "echo" as an example:
		$ grep echo /etc/services
		echo            7/tcp
		echo            7/udp

Although /etc/xinetd.d/echo and /etc/xinetd.d/echo-udp are different file names
both MUST have "echo" on the "service" line (because there's no such service
called "echo-udp"

# ls -l /etc/xinetd.d/echo*
-rw-r--r--    1 root     root          288 May  3 13:01 echo
-rw-r--r--    1 root     root          343 May  3 13:00 echo-udp


# cat /etc/xinetd.d/echo
# default: off
# description: An echo server. This is the tcp \
# version.

service echo
{
        type            = INTERNAL
        id              = echo-stream
        socket_type     = stream
        protocol        = tcp
        user            = root
        wait            = no
        disable         = no
}                                                                               

# cat /etc/xinetd.d/echo-udp
# default: off
# description: An echo server. This is the udp \
# version.

# Removed -udp (bugzilla bug 38669)
service echo
{
        type            = INTERNAL UNLISTED
        id              = echo-dgram
        socket_type     = dgram
        protocol        = udp
        user            = root
        wait            = yes
        disable         = no
        port            = 7
}                                                                               

 # netstat -a |grep echo
tcp        0      0 *:echo                  *:*                     LISTEN      
udp        0      0 *:echo                  *:*                                 
Comment 3 Trond Eivind Glomsrxd 2001-05-03 16:52:16 EDT
I know that - the problems is handling it in ntsysv and chkconfig, which needs
unique names for services: Note that I specify the port in an attempt at making
xinetd run it with a different name.
Comment 4 Dan Anderson 2001-05-19 18:46:32 EDT
OK. Thanks for the comment.
Let me just add that it sounds like ntsysv and chkconfig need to be fixed.
Service names could be the same for both TCP and UDP and that this has long
been standardized before ntsysv or chkconfig have existed.
Comment 5 Trond Eivind Glomsrxd 2001-05-20 15:38:43 EDT
A fix is in xinetd-2.1.8.9pre15-1.
Comment 6 Trond Eivind Glomsrxd 2001-07-20 15:37:58 EDT
*** Bug 49564 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.