Bug 387141 - SD/MMC Winbond driver causes kernel panic at boot
SD/MMC Winbond driver causes kernel panic at boot
Status: CLOSED DUPLICATE of bug 449817
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 11:25 EST by Grégory SCHMITT
Modified: 2008-10-05 17:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-05 17:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash log at startup (139.25 KB, image/jpeg)
2007-11-16 18:05 EST, Grégory SCHMITT
no flags Details
Custom kernel config file (33.75 KB, text/plain)
2007-11-17 05:19 EST, Grégory SCHMITT
no flags Details

  None (edit)
Description Grégory SCHMITT 2007-11-16 11:25:53 EST
Description of problem:
After installing Fedora 8 (for i386 architecture), the Winbond driver (module
wbsd) for a SD/MMC card reader causes a kernel panic at boot upon probing.
Computer has an AMD x64 cpu. Bug was also present in Fedora 7.

How reproducible:
always.
 
Actual results:
kernel panic and computer crash.

Additional info:
The solution is to use the Fedora 8 DVD, to boot in rescue mode and to blacklist
the wbsd driver in /etc/modprobe.d/blacklist.

With a custom kernel (compiled by me), the computer starts and the driver works
correctly; cards can be read successfully.
Comment 1 Chuck Ebbert 2007-11-16 12:38:30 EST
Please post the error messages.
Comment 2 Grégory SCHMITT 2007-11-16 17:15:19 EST
<...lot of text, numbers that I can't copy...>
Kernel Panic - not syncing: Fatal exception in interrupt

If needeed, I could take a snapshot of the screen...
Comment 3 Chuck Ebbert 2007-11-16 17:33:35 EST
Yes, a picture is fine.
Comment 4 Grégory SCHMITT 2007-11-16 18:05:25 EST
Created attachment 261941 [details]
Crash log at startup
Comment 5 Grégory SCHMITT 2007-11-17 05:19:16 EST
Created attachment 262181 [details]
Custom kernel config file

With this kernel config, startup is fine, module is OK and cards are read
successfully.
Comment 6 Chuck Ebbert 2007-11-19 18:14:53 EST
(In reply to comment #4)
> Created an attachment (id=261941) [edit]
> Crash log at startup
> 

Unforunately the entire message is not visible. Adding vga=791 to the kernel
boot options will give a lot more lines.

Comment 7 Chuck Ebbert 2007-11-19 18:15:27 EST
(In reply to comment #5)
> Created an attachment (id=262181) [edit]
> Custom kernel config file
> 
> With this kernel config, startup is fine, module is OK and cards are read
> successfully.

There is no way to tell which of the hundreds of options that were changed made
a difference...
Comment 8 Grégory SCHMITT 2007-11-21 09:44:14 EST
Here's the beginning of the crash log:

kernel BUG at kernel/softirq.c:406!
invalid opcode: 0000 [#1] SMP
...

I've tried several boot options (irqfixup, irqpoll, acpi=noirq, pci=biosirq,
irqbalance) and none of them worked.
Comment 9 Chuck Ebbert 2007-11-21 15:27:05 EST
Does blacklisting the sdhci driver work as well?

And please post output of 'lspci' and 'lspci -vn' commands.
Comment 10 Grégory SCHMITT 2008-01-01 11:58:14 EST
-- lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:0a.0 Network controller: Intersil Corporation ISL3890 [Prism GT/Prism
Duette]/ISL3886 [Prism Javelin/Prism Xbow] (rev 01)
00:0b.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0b.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0b.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 02)
00:0c.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller
(rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]

-- lspci -vn
00:00.0 0600: 1106:3188 (rev 01)
	Subsystem: 17c0:4020
	Flags: bus master, 66MHz, medium devsel, latency 0
	Memory at e0000000 (32-bit, prefetchable) [size=256M]
	Capabilities: <access denied>

00:01.0 0604: 1106:b188 (prog-if 00 [Normal decode])
	Flags: bus master, 66MHz, medium devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 00002000-00002fff
	Memory behind bridge: d0100000-d01fffff
	Prefetchable memory behind bridge: d8000000-dfffffff
	Capabilities: <access denied>

00:0a.0 0280: 1260:3890 (rev 01)
	Subsystem: 17cf:0014
	Flags: bus master, medium devsel, latency 80, IRQ 18
	Memory at d0000000 (32-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>

00:0b.0 0607: 1180:0476 (rev aa)
	Subsystem: 17c0:3302
	Flags: bus master, medium devsel, latency 168, IRQ 16
	Memory at 40010000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=00, secondary=02, subordinate=05, sec-latency=176
	Memory window 0: 30000000-33fff000 (prefetchable)
	Memory window 1: 34000000-37fff000
	I/O window 0: 00001c00-00001cff
	I/O window 1: 00003000-000030ff
	16-bit legacy interface ports at 0001

00:0b.1 0607: 1180:0476 (rev aa)
	Subsystem: 17c0:3302
	Flags: bus master, medium devsel, latency 168, IRQ 17
	Memory at 40011000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=00, secondary=06, subordinate=09, sec-latency=176
	Memory window 0: 38000000-3bfff000 (prefetchable)
	Memory window 1: 3c000000-3ffff000
	I/O window 0: 00003400-000034ff
	I/O window 1: 00003800-000038ff
	16-bit legacy interface ports at 0001

00:0b.2 0c00: 1180:0552 (rev 02) (prog-if 10 [OHCI])
	Subsystem: 17c0:107a
	Flags: bus master, medium devsel, latency 64, IRQ 20
	Memory at d0002000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: <access denied>

00:0c.0 0200: 14e4:4401 (rev 01)
	Subsystem: 17c0:1082
	Flags: bus master, fast devsel, latency 64, IRQ 19
	Memory at d0004000 (32-bit, non-prefetchable) [size=8K]
	[virtual] Expansion ROM at 40000000 [disabled] [size=64K]
	Capabilities: <access denied>

00:10.0 0c03: 1106:3038 (rev 80) (prog-if 00 [UHCI])
	Subsystem: 17c0:1091
	Flags: bus master, medium devsel, latency 64, IRQ 18
	I/O ports at 1020 [size=32]
	Capabilities: <access denied>

00:10.1 0c03: 1106:3038 (rev 80) (prog-if 00 [UHCI])
	Subsystem: 17c0:1091
	Flags: bus master, medium devsel, latency 64, IRQ 18
	I/O ports at 1040 [size=32]
	Capabilities: <access denied>

00:10.2 0c03: 1106:3038 (rev 80) (prog-if 00 [UHCI])
	Subsystem: 17c0:1091
	Flags: bus master, medium devsel, latency 64, IRQ 18
	I/O ports at 1060 [size=32]
	Capabilities: <access denied>

00:10.3 0c03: 1106:3104 (rev 82) (prog-if 20 [EHCI])
	Subsystem: 17c0:1092
	Flags: bus master, medium devsel, latency 64, IRQ 18
	Memory at d0002800 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>

00:11.0 0601: 1106:3177
	Subsystem: 17c0:402c
	Flags: bus master, stepping, medium devsel, latency 0
	Capabilities: <access denied>

00:11.1 0101: 1106:0571 (rev 06) (prog-if 8a [Master SecP PriP])
	Subsystem: 17c0:4022
	Flags: bus master, medium devsel, latency 64
	[virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
	[virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
	[virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
	[virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
	I/O ports at 1000 [size=16]
	Capabilities: <access denied>

00:11.5 0401: 1106:3059 (rev 50)
	Subsystem: 17c0:200d
	Flags: medium devsel, IRQ 21
	I/O ports at 1400 [size=256]
	Capabilities: <access denied>

00:11.6 0780: 1106:3068 (rev 80)
	Subsystem: 17c0:109d
	Flags: medium devsel, IRQ 21
	I/O ports at 1800 [size=256]
	Capabilities: <access denied>

00:18.0 0600: 1022:1100
	Flags: fast devsel
	Capabilities: <access denied>

00:18.1 0600: 1022:1101
	Flags: fast devsel

00:18.2 0600: 1022:1102
	Flags: fast devsel

00:18.3 0600: 1022:1103
	Flags: fast devsel

01:00.0 0300: 1002:4e50 (prog-if 00 [VGA])
	Subsystem: 17c0:2061
	Flags: bus master, 66MHz, medium devsel, latency 24, IRQ 22
	Memory at d8000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 2000 [size=256]
	Memory at d0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at d0120000 [disabled] [size=128K]
	Capabilities: <access denied>

Comment 11 Christopher Brown 2008-02-13 17:24:49 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel? Were you able to test with
blacklisting the driver as Chuck indicated?

If the problem no longer exists then please close this bug or I'll do so in a
few weeks if there is no additional information lodged.
Comment 12 Grégory SCHMITT 2008-02-19 21:13:08 EST
Blacklisting the driver won't help, unfortunately, as sdhci is not the right
driver - wbsd is. Blacklisting wbsd will fix the crash at boot issue, but of
course, the device won't work. Manually probing the module later will trigger
the crash.

As for the latest kernel, I can't really tell so far you since I run on a custom
kernel and I usually don't do any upgrade. Would you like me to try it ?
Comment 13 Christopher Brown 2008-02-24 10:50:46 EST
(In reply to comment #12)

> As for the latest kernel, I can't really tell so far you since I run on a custom
> kernel and I usually don't do any upgrade. Would you like me to try it ?

Yes please, the Fedora developers won't support a custom kernel. There is a
2.6.24-based kernel in updates-testing available for you to try.
Comment 14 Grégory SCHMITT 2008-02-24 11:42:16 EST
(In reply to comment #13)

> Yes please, the Fedora developers won't support a custom kernel. There is a
> 2.6.24-based kernel in updates-testing available for you to try.

Just tried the 2.6.24 update. Same crash. It has to be an option in my ustom
kernel config, but which one...
Comment 15 Christopher Brown 2008-02-26 17:02:04 EST
Maybe check (and post) a diff of the two configs?
Comment 16 Grégory SCHMITT 2008-02-26 18:23:27 EST
There are so many changes from one config to the other that it would be a waste
of time. I wish I had a hint of a solution regarding which modules are involved
in the crash.
Comment 17 Grégory SCHMITT 2008-10-05 17:04:42 EDT
Bug has been fixed: https://bugzilla.redhat.com/show_bug.cgi?id=449817
Comment 18 Grégory SCHMITT 2008-10-05 17:05:51 EDT

*** This bug has been marked as a duplicate of bug 449817 ***

Note You need to log in before you can comment on or make changes to this bug.