Bug 449817 - SD card reader causes kernel panic during startup if card inserted
Summary: SD card reader causes kernel panic during startup if card inserted
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 387141 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-03 19:03 UTC by Oliver Clark
Modified: 2008-10-05 21:05 UTC (History)
1 user (show)

Fixed In Version: 2.6.25.6-55.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-13 02:27:12 UTC
Type: ---


Attachments (Terms of Use)
Photo of kernel panic (156.85 KB, image/jpeg)
2008-06-03 19:03 UTC, Oliver Clark
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 10879 0 None None None Never

Description Oliver Clark 2008-06-03 19:03:43 UTC
Description of problem:
If there is an SD memory card or dummy (dust protector) card inserted into the laptops inbuilt card 
reader during startup the computer will kernel panic.

If there is nothing in the slot the computer will startup ok and is able to read and write to SD cards.

The problem also occurs with Fedora 8.

How reproducible:
Always

Steps to Reproduce:
1. Insert SD card or dummy card into card reader
2. Power up computer

Additional info:
I am unsure on how to get a copy of the actual error text so I have attached a photo of it.

The version of the kernel is:
2.6.25.3-18.fc9.x86_64

The last line I see before the panic occurs is:
Starting udev:

lspci output:
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:0a.0 Network controller: Intersil Corporation ISL3890 [Prism GT/Prism Duette]/ISL3886 [Prism 
Javelin/Prism Xbow] (rev 01)
00:0b.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0b.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0b.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 02)
00:0c.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus 
Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio 
Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport 
Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
02:00.0 Network controller: RaLink RT2600 802.11 MIMO

Comment 1 Oliver Clark 2008-06-03 19:03:43 UTC
Created attachment 308282 [details]
Photo of kernel panic

Comment 2 Chuck Ebbert 2008-06-07 00:41:50 UTC
kernel/softirq.c:409:
            if (!test_and_clear_bit(TASKLET_STATE_SCHED, &t->state))
                    BUG();

Tasklet gets initialized after being scheduled, clearing the bit.

Comment 3 Chuck Ebbert 2008-06-10 01:27:57 UTC
Fix went into kernel 2.6.25.6-53

Comment 4 Fedora Update System 2008-06-12 01:38:45 UTC
kernel-2.6.25.6-55.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-06-13 02:26:45 UTC
kernel-2.6.25.6-55.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Kurian John 2008-06-15 12:14:29 UTC
Kernel 2.6.25.6-55.fc9 panics during startup on my HP pavilion dv6255. Earlier
kernels used to work fine.
lspci output:

00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation C51 [Geforce 6150 Go] (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
07:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
07:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host
Adapter (rev 19)
07:05.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 0a)
07:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev 05)
07:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)


Comment 7 Oliver Clark 2008-06-15 12:34:10 UTC
I've just installed and tested kernel-2.6.25.6-55.fc9 on my laptop.

The laptop now starts up correctly with either an SD card or the dummy card inserted.

Comment 8 Grégory SCHMITT 2008-10-05 21:05:51 UTC
*** Bug 387141 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.