Bug 38755 - Compiling LAME with nasm installed creates segfaulting copy of LAME
Compiling LAME with nasm installed creates segfaulting copy of LAME
Status: CLOSED DUPLICATE of bug 27489
Product: Red Hat Linux
Classification: Retired
Component: nasm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-02 11:00 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 11:00:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-02 11:00:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Using LAME sources (3.88beta or 3.89alpha), with the RH7.1 nasm-0.98-6 RPM 
installed, LAME compiles and installs successfully, but the resulting 
binary causes a segfault before it begins doing any encoding. Compiling 
and installing nasm from the nasm sources (0.98) produces a functional 
copy of LAME.

Reproducible: Always
Steps to Reproduce:
1. Download LAME 3.88 sources from www.mp3dev.org
2. Configure, make and install
3. Attempt encoding of a WAV file to MP3 with VBR mode enabled.
	

Actual Results:  LAME segfaults and dumps core.

Expected Results:  Successful MP3 encoding.

I am using an Celeron 700 (Coppermine), so the LAME configure script is 
including MMX and SIMD instructions if it finds nasm present on the 
system. With no nasm installed at all, LAME also compiles and works fine, 
it's just slower :-(
Comment 1 Trond Eivind Glomsrxd 2001-05-02 11:12:35 EDT
This should be fixed in nasm 0.98-7, which should show up in Rawhide soonish.

*** This bug has been marked as a duplicate of 27489 ***

Note You need to log in before you can comment on or make changes to this bug.