Bug 38791 - Software RAID won't autorun
Summary: Software RAID won't autorun
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Ingo Molnar
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 40586 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-02 18:10 UTC by Chris Adams
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-04 20:10:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fs/partitions/osf.c to enable RAID autorun (1.12 KB, patch)
2001-05-02 18:11 UTC, Chris Adams
no flags Details | Diff

Description Chris Adams 2001-05-02 18:10:59 UTC
Software RAID does not autorun on any platform that doesn't use MSDOS style
partition tables because the only partition type in fs/partitions that
calls md_autodetect_dev() is msdos.c.

I'm attaching a patch that should make RAID autorun work on OSF partitions
(although I cannot test it yet, since the installer crashes on me - bug
#38790).  Ideally, the add_gd_partition() function would be like the
add_partition() function in 2.2, where the partition type was passed in (or
just 0 if partitions didn't have types) and add_gd_partition would then
have the logic to call md_autodetect_dev().

Comment 1 Chris Adams 2001-05-02 18:11:35 UTC
Created attachment 17068 [details]
Patch to fs/partitions/osf.c to enable RAID autorun

Comment 2 Arjan van de Ven 2001-05-02 19:38:29 UTC
Ingo: can you take a peek at this?

Comment 3 Chris Adams 2001-05-24 18:16:00 UTC
One other (possibly obvious) comment on this, especially since the release notes
with RC1 suggest software RAID: compile the RAID modules in to the default
kernel.  The above patch is useless without that.

Comment 4 Phil Copeland 2001-06-04 20:00:02 UTC
Ingo? Arjan? anybody?
The above patch is not in the current cvs, is this a patch that we want? reject
or apply?



Comment 5 Phil Copeland 2001-06-04 20:10:10 UTC
*** Bug 40586 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.