Bug 388201 - (pirut) pirut crashs after search
pirut crashs after search
Status: CLOSED DUPLICATE of bug 252136
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 04:51 EST by Karlheinz Blau
Modified: 2010-10-16 12:14 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 11:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
created by the system (641.90 KB, application/octet-stream)
2007-11-17 04:51 EST, Karlheinz Blau
no flags Details
manager (1.62 KB, text/plain)
2008-03-22 03:33 EDT, AdITyA
no flags Details
Error from package update (2.61 KB, text/plain)
2008-10-01 07:37 EDT, Roger Carlson
no flags Details
is about pirut (1.92 KB, application/octet-stream)
2008-11-11 10:30 EST, daniele archilei
no flags Details
bug during updates (1.61 KB, application/octet-stream)
2008-11-19 14:02 EST, jmurray
no flags Details
Crash dump output. (3.19 KB, text/plain)
2010-04-23 07:05 EDT, Jean-David Beyer
no flags Details

  None (edit)
Description Karlheinz Blau 2007-11-17 04:51:12 EST
Description of problem: After starting a search it crashs


Version-Release number of selected component (if applicable):


How reproducible: Start and serarch


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Karlheinz Blau 2007-11-17 04:51:12 EST
Created attachment 262171 [details]
created by the system
Comment 2 Jeremy Katz 2007-11-19 11:17:33 EST

*** This bug has been marked as a duplicate of 252136 ***
Comment 3 AdITyA 2008-03-22 03:33:02 EDT
Created attachment 298822 [details]
manager
Comment 4 Roger Carlson 2008-10-01 07:37:28 EDT
Created attachment 318183 [details]
Error from package update

I got this error when attempting to apply the recommended package updates to my Fedora 8 system.
Comment 5 daniele archilei 2008-11-11 10:30:01 EST
Created attachment 323179 [details]
is about pirut
Comment 6 jmurray 2008-11-19 14:02:33 EST
Created attachment 324085 [details]
bug during updates

Received this during updates on fedora.
Comment 7 bitu 2009-11-21 07:33:00 EST
Here is the exception message: 

Component: pirut
Summary: TB69bef1f8 config.py:86:__set__:ValueError: Error parsing '1enabled=1': invalid boolean value

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 490, in ?
    main()
  File "/usr/sbin/pirut", line 483, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 67, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 170, in doConfigSetup
    return self.conf
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 664, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 245, in _getConfig
    self.getReposFromConfig()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 338, in getReposFromConfig
    self.getReposFromConfigFile(self.conf.config_file_path, repo_config_age)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 312, in getReposFromConfigFile
    thisrepo = self.readRepoConfig(parser, section)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 362, in readRepoConfig
    repo.populate(parser, section, self.conf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 493, in populate
    setattr(self, name, value)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 86, in __set__
    raise ValueError('Error parsing %r: %s' % (value, str(e)))
ValueError: Error parsing '1enabled=1': invalid boolean value

Local variables in innermost frame:
obj: atrpms
self: <yum.config.BoolOption object at 0x976078c>
e: invalid boolean value
value: 1enabled=1
Comment 8 Helen Imogen Field 2009-11-24 12:04:53 EST
Software Package Updater fails to work because of a probable bug (as reported by Package Updater)
Red Hat Enterprise Linux Client release 5.4 (Tikanga)
managed by RHN

Component: pirut
Summary: TB640f79e5 rhnplugin.py:313:_getFile:RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-x86_64-client-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 613, in main
    pup.run()
  File "/usr/sbin/pup", line 451, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 291, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 347, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 367, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1484, in retrieveMD
    return self._retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1524, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 313, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-x86_64-client-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: rhel-x86_64-client-5/updateinfo
self: rhel-x86_64-client-5
cache: False
reget: None
relative: repodata/updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at 0x14f12d0>>, ('updateinfo',), {})
copy_local: 1
end: None
local: /var/cache/yum/rhel-x86_64-client-5/updateinfo.xml.gz
Comment 9 Jean-David Beyer 2010-04-23 07:05:19 EDT
Created attachment 408576 [details]
Crash dump output.

I was accepting an update to my RH Enterprise Linux 5 system and it seemed to work except it crashed during the cleanup phase. The pop up requested I submit this.
Comment 10 Joel Charbonnet 2010-10-16 12:14:55 EDT
RHEL 5.5

Component: pirut
Summary: TB3e4030d0 rhnserver.py:64:__call__:SSLCertificateVerifyFailedError: The SSL certificate failed verification.

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 361, in ?
    main()
  File "/usr/sbin/system-install-packages", line 354, in main
    pkginst = SinglePackageInstaller()
  File "/usr/sbin/system-install-packages", line 66, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 170, in doConfigSetup
    return self.conf
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 664, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 253, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 111, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 217, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 184, in login
    li = server.up2date.login(systemId)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 64, in __call__
    raise up2dateErrors.SSLCertificateVerifyFailedError()
SSLCertificateVerifyFailedError: The SSL certificate failed verification.

Local variables in innermost frame:
args: ('<?xml version="1.0"?>\n<params>\n<param>\n<value><struct>\n<member>\n<name>username</name>\n<value><string>CharboSoft</string></value>\n</member>\n<member>\n<name>operating_system</name>\n<value><string>redhat-release</string></value>\n</member>\n<member>\n<name>description</name>\n<value><string>Initial Registration Parameters:\nOS: redhat-release\nRelease: 5Client\nCPU Arch: x86_64-redhat-linux</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>92f9682a5054832421911dfd0d83620e</string></value>\n</member>\n<member>\n<name>profile_name</name>\n<value><string>CharboSoft</string></value>\n</member>\n<member>\n<name>system_id</name>\n<value><string>ID-1018092145</string></value>\n</member>\n<member>\n<name>architecture</name>\n<value><string>x86_64-redhat-linux</string></value>\n</member>\n<member>\n<name>os_release</name>\n<value><string>5Client</string></value>\n</member>\n<member>\n<name>fields</name>\n<value><array><data>\n<value><string>system_id</string></value>\n<value><string>os_release</string></value>\n<value><string>operating_system</string></value>\n<value><string>architecture</string></value>\n<value><string>username</string></value>\n<value><string>type</string></value>\n</data></array></value>\n</member>\n<member>\n<name>type</name>\n<value><string>REAL</string></value>\n</member>\n</struct></value>\n</param>\n</params>\n',)
e: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]
self: <up2date_client.rhnserver._DoCallWrapper object at 0xb484f90>
error: 'SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed'
pieces: ["'SSL routines'", " 'SSL3_GET_SERVER_CERTIFICATE'", " 'certificate verify failed'"]
kwargs: {}
message: certificate verify failed

Note You need to log in before you can comment on or make changes to this bug.