Bug 38891 - /sbin/pam_console_apply called before /usr is mounted
/sbin/pam_console_apply called before /usr is mounted
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: pam (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-03 04:57 EDT by Enrico Scholz
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: pam-0.75
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 11:07:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-05-03 04:57:13 EDT
[perhaps this is a pam-issue...]

/sbin/pam_console_apply is linked against glib:

--------------------
$ ldd /sbin/pam_console_apply 
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x40027000)
        libc.so.6 => /lib/i686/libc.so.6 (0x4004c000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
---------------------

Because /usr is NFS-mounted at my system, /usr/lib/libglib is not available
in early init-stages. But /sbin/pam_console_appy is called by
/etc/rc.d/rc.sysinit before the netfs-scripts.

So I get at boot an error-messages saying that the libglib library is
missing.
Comment 1 Bill Nottingham 2001-05-03 11:54:14 EDT
Nalin: you want to statically link it against glib?
Comment 2 Tomas Mraz 2005-09-13 11:07:14 EDT
This is already fixed for a long time.

Note You need to log in before you can comment on or make changes to this bug.