Bug 389491 - No sound on Fedora 8 with 82801H
No sound on Fedora 8 with 82801H
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 12:05 EST by sruohola
Modified: 2008-02-26 05:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 05:13:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log and scsrun.log which were printed when tried to play a test sound in system-config-soundcard (53.80 KB, text/plain)
2007-11-18 12:05 EST, sruohola
no flags Details

  None (edit)
Description sruohola 2007-11-18 12:05:36 EST
Description of problem:

No sound on Fedora 8, i386, with Intel 82801H.
Maybe similar to bug number 384261,
https://bugzilla.redhat.com/show_bug.cgi?id=384261
but does not work with my laptop.
I have a Zepto laptop.

I am not sure to which component this belongs to.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sruohola 2007-11-18 12:05:36 EST
Created attachment 262991 [details]
scsconfig.log and scsrun.log which were printed when tried to play a test sound in system-config-soundcard
Comment 2 sruohola 2007-11-20 14:42:27 EST
# uname -a
Linux localhost.localdomain 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007
i686 i686 i386 GNU/Linux
Comment 3 Martin Stransky 2007-11-26 17:33:40 EST
Log looks sane, drivers are loaded and the sound card seems to be properly
detected and configured. I don't see any problem there. Please report it to ALSA
project (www.alsa-project.org) and attach the log there. 
Comment 4 mail 2007-11-26 21:19:12 EST
I had similar pb but now solved

I created file /etc/modprobe.d/alsa-base with an entry:
'options snd-hda-intel model=acer-aspire'

This unexpectedly solved it, because my laptop is not an acer!

have a look at
http://www.mjmwired.net/kernel/Documentation/sound/alsa/ALSA-Configuration.txt

the value 'acer-aspire' is not suggested foor the ALC883, 'acer' is.

hth

Comment 5 sruohola 2007-11-27 15:18:39 EST
Thanks for the tips!
I found this mentioned in one discussion group too, one Zepto laptop was
mentioned there.

At least these seam to make the sound work, I can hear the sound now:

/etc/modprobe.d/alsa-base:
options snd-hda-intel model=acer

/etc/modprobe.conf:
alias eth0 tg3
alias scsi_hostadapter libata
alias scsi_hostadapter1 ata_piix
alias scsi_hostadapter2 ahci
options snd cards_limit=8
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=acer

Headphones do not disable the speakers.
Others have reported this too.
But it is enough for me that the sound works!


I had also removed pulseaudio. 
And I reinstalled alsa related libraries etc. with Smart Package Manager.
But I do not know do those affect to the sound.
(Just to mention what different kinds of issues I have done.)

Correct settings in the above configuration files might help without making any
other changes.
Comment 6 Will Woods 2007-12-03 14:50:57 EST
so adding "options snd-hda-intel model=acer" fixed your sound?

Martin, is this something that gets fixed in the kernel, or somewhere else like
alsa configuration stuff?
Comment 7 Martin Stransky 2007-12-07 06:50:05 EST
It has to be fixed in kernel (alsa-drivers) or in alsa-lib. We can't manage a
table for all hardware models and its specific configuration... It's definitely
an upstream issue.
Comment 8 sruohola 2007-12-10 00:14:23 EST
(In reply to comment #6)
> so adding "options snd-hda-intel model=acer" fixed your sound?
> 

Yes.
It seems it is enough to add only the "alsa-base" file with the mentioned text
in it:

[root@localhost ~]# cat /etc/modprobe.d/alsa-base
options snd-hda-intel model=acer

( I took the original /etc/modprobe.conf file in use and the upper "alsa-base"
file was in use and sound worked still. )
Comment 9 Martin Stransky 2008-02-26 05:13:15 EST
Closing as wontfix.

Note You need to log in before you can comment on or make changes to this bug.