Bug 39029 - RFE: Need boot disks for systems with USB floppy drives
RFE: Need boot disks for systems with USB floppy drives
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
: 41172 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-05-03 15:45 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-11 16:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-03 15:45:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
On a Sony 505fx (64M Ram, PII 266mhz, 4GB HD, pccard CDROM(cdrw52)) using 
a boot floppy created with rawrite from the 7.1 Professional Boxed Set CD 
1, with either the boot.img or pcmcia.img files, Set up gets to the first 
screen, the screen with all the different options and the boot: prompt at 
the bottom.  I choose any installation option and the system responds:
Loading initrd.img..............
Loading vmlinuz.....
Boot failed:  please change disks and press a key to continue

1.  I have used rawrite and the boot.img from this CDRom to successuflly 
boot and install on a different machine (Dell desktop) so I don't suspect 
the disk.
2.  It doesn't seem to matter if there is anything in the pcmcia slot, I 
have tried the CDROM(sony cdrw52), a wireless network card(Aviator),and 
nothing.  They all produce the result recorded above.
3.  I suspect it is something in the kernel that doesn't like the basic 
setup on this laptop.  What causes the code to spit out the "Boot Failed:" 
4.  Bios on this machine, Pheonix BIOS 4.0 release 6, doesn't support 
booting from the pcmcia slot.

How reproducible:

Steps to Reproduce:
1.  Attempt Install from Floppy created with rawrite on Sony 505fx laptop.

Actual Results:  
Loading initrd.img..............
Loading vmlinuz.....
Boot failed:  please change disks and press a key to continue

Expected Results:  Linux Install screens

Additional info:

System does not hang up at this point, pressing the enter key reproduces 
the login selection text.
Comment 1 David M. Cook 2001-05-08 15:28:02 EDT
Moved to correct product (Red Hat 7.1) and component (installer).
Comment 2 carpnic 2001-05-31 08:31:30 EDT
I have a similar problem trying to install rh7.1 onto a Sharp Actius PC-AX10 
ultralight notebook. The laptop comes with a usb bootable floppy drive. I had 
no problems installing rh7.0 using bootnet.img disk but when using the new 
rh7.1 images it stops at vmlinuz... and no other messages and locks up the 
computer and keyboard. None of the boot images work.

Can the older images be used to install the newer version or can i create my 
own install disk?

Mine is not a boxed set but from a computer mag.

Comment 3 Cristian Gafton 2001-05-31 14:23:04 EDT
assigned to the right owner
Comment 4 Brent Fox 2001-05-31 15:30:17 EDT
Are you sure that the boot disks are ok?  The "boot failed" message usually
means that there's something wrong with the floppy.  

Can you boot from the cdrom drive?
Comment 5 carpnic 2001-06-02 00:44:28 EDT
I am the sharp owner. Mine does not come up with a "Boot failed" error like the 
sony owner. I didn't create a new bug report since the error is similar.

In my case i don't have the cdrom option for this machine as it was too 
expensive. I am trying to install via ftp since the notebook has a built in 
network card. I have tried the cd and the boot disk in a desk top and both boot 
ok. The boot disk fails on the vmlinuz image load on the notebook
Loading initrd.img..............
Loading vmlinuz...

It then just hangs the system until i switch it off.

Comment 6 Brent Fox 2001-06-04 11:56:07 EDT
Carl, we've had a number of reports about installation problems on various
sub-notebooks...all with the same basic problem.  It seems that many people
don't get the CDROM option because of the high price.  So, they are forced to
use the boot disks.  

For laptop systems, you need two floppy disks.  The first one (pcmcia.img) is
the boot disk, and the second one (pcmciadd.img) is the driver disk.  Here's the
crux of the problem:  they floppy device is usually a USB device on these kinds
of systems.  The BIOS supports booting off the USB floppy, so the boot disk gets
loaded.  The boot disk then prompts you for the driver disk, but the USB drivers
necessary to load the driver disk are not on the first disk...they are on the
driver disk.  So, it's a chicken and egg problem.  

The problem is that there is so little room on the boot disks.  A possiblity for
future releases is to make another set of boot disks for all-USB systems. 
Unfortunately, I can't think of a workaround for you with 7.1 unless you can
borrow a CDROM drive to do the install with.  :(
Comment 7 carpnic 2001-06-04 21:45:14 EDT

Yes i did find that problem out with the pcmcia disks. My alternatives were to
install via ftp using the single bootnet disk. I have a desktop machine runnung
rh6.1 with a network card installed, the notebook also has a network card built
in. I used the bootnet.img boot disk from rh7.0 edition and i have successfully
installed rh7.0 onto the notebook using ftp. What i wanted to do was
update/reinstall to rh7.1 on the notebook, but the new bootnet disk from rh7.1
no longer boots. It just seems strange that rh7.0 disks boot ok and rh7.1 do not.
I will be looking a borrowing a cdrom from the people i bought it from or grit
my teeth and buy one.

thanks for your help
Comment 8 Brent Fox 2001-06-11 11:58:37 EDT
The difference between the boot disks is that we switched to the 2.4 kernel in
7.1.  The 2.4 kernel is bigger than 2.2 (no matter how much we stripped out for
the boot disk kernel), so that took up even more space on the boot disk.  

I know I'm stating the painfully obvious here, but floppies just aren't big
enough for many uses these days.  Subnotebooks and other devices without CDROM
drives are going to become an even bigger problem if the floppy is the only way
to get data onto them.  It's just a limitation of the hardware...it would be
nice if you could netboot them with something like PXE, but that requires work
from the hardware makers.

I'm turning this into an RFE for specialized boot disks for all USB devices.
Comment 9 Brent Fox 2001-06-26 18:10:01 EDT
*** Bug 41172 has been marked as a duplicate of this bug. ***
Comment 10 Michael Fulbright 2001-07-27 16:34:07 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.