Bug 39071 - Installer crashed unable to mount hda2 to begin install of software
Installer crashed unable to mount hda2 to begin install of software
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-05-03 21:37 EDT by mfreeman75
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-04 11:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Dump file of error (768 bytes, patch)
2001-05-03 21:38 EDT, mfreeman75
no flags Details | Diff

  None (edit)
Description mfreeman75 2001-05-03 21:37:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
I am installing to an IBM laptop A20m. I successfully installed this 
software before on this laptop with another harddisk using the Graphical 
install as a workstation. This time I was using the custom install 
following the instructions in the book: "Red Hat Linux 7 Weekend Crash 
course". Everything went fine up to completing the video selection and it 
was time to begin the installation and it gave me an error trying to mount 
hda2 with the attached logfile. 

How reproducible:

Steps to Reproduce:
1.Use Druid to create partitions Root and Swap on 2Gig partition
2.Complete all selection criteria
3.Begin installation

Actual Results:  error message mounting hda2

Expected Results:  Installation should have proceeded normally

Additional info:

Here's the error message I saved!

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472,
in doInstall
    self.fstab.mountFilesystems (self.instPath)
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713,
in mountFilesystems
    raise SystemError, (errno, msg)
(22, 'Invalid argument')

Local variables in innermost frame:
fsystem: ext2
self: <fstab.GuiFstab instance at 84284c8>
Invalid argument
doFormat: 0
errno: 22
device: hda2
instPath: /mnt/sysimage

ToDo object:


Comment 1 mfreeman75 2001-05-03 21:38:36 EDT
Created attachment 17287 [details]
Dump file of error
Comment 2 Brent Fox 2001-05-04 11:23:13 EDT

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.