This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 391101 - An unhandled exception has occured
An unhandled exception has occured
Status: CLOSED DUPLICATE of bug 252136
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 17:09 EST by tom lehmann
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 17:29:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tom lehmann 2007-11-19 17:09:10 EST
Description of problem:
When I try a Software-Update, pirut crashes with "An unhandled exception has
occured"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Component: pirut
Summary: TB8bc72d62 gettext.py:313:_parse:AttributeError: 'list' object has no
attribute 'split'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 116, in _pageSwitch
    self.pageMap[num]()
  File "/usr/sbin/pirut", line 296, in _showListReal
    plist.addPackage(po, t)
  File "/usr/lib/python2.5/site-packages/pirut/PackageList.py", line 142, in
addPackage
    listEntryString(po), type])
  File "/usr/lib/python2.5/site-packages/pirut/PackageList.py", line 66, in
listEntryString
    desc = "<b>%s</b> - %s" %(po, pirut.sanitizeString(desc))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 833, in
sanitizeString
    r = gettext.dgettext(d, s)
  File "/usr/lib/python2.5/gettext.py", line 530, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.5/gettext.py", line 478, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.5/gettext.py", line 313, in _parse
    v = v.split(';')
AttributeError: 'list' object has no attribute 'split'

Local variables in innermost frame:
msgcount: 2956
tmsg: #-#-#-#-#  de.po (de)  #-#-#-#-#
Project-Id-Version: de
POT-Creation-Date: 2007-04-17 08:35+0000
PO-Revision-Date: 2006-12-08 12:01+1000
Last-Translator: PGP-KeyID: 0x037FD3CF <ttrinks@redhat.com>
Language-Team:  <en@li.org>
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
X-Generator: KBabel 1.9.1
X-Generator: KBabel 1.9.1
Plural-Forms: nplurals=2; plural=(n != 1);
Comment 1 Jeremy Katz 2007-11-19 17:29:07 EST

*** This bug has been marked as a duplicate of 252136 ***

Note You need to log in before you can comment on or make changes to this bug.