Bug 391781 - Citrix ICA crashes with xcb_xlib_lock: Assertion
Citrix ICA crashes with xcb_xlib_lock: Assertion
Status: CLOSED DUPLICATE of bug 390261
Product: Fedora
Classification: Fedora
Component: libxcb (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
Blocks: c->xlib.lock
  Show dependency treegraph
Reported: 2007-11-20 05:01 EST by Martin Ebourne
Modified: 2008-01-10 07:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-10 07:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Martin Ebourne 2007-11-20 05:01:20 EST
Description of problem:
Citrix ICA client crashes with this error:
wfica: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Run Citrix ICA client
Actual results:
wfica: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.

Expected results:
Application should work

Additional info:
I know this is a bug in the citrix client and I know this is binary crap but
unfortunately I have to run it and citrix are unlikely to fix it any time soon.

There seems to be a lot of collateral damage from this assert, in the next
version of libxcb upstream has provided a workaround for this issue. Can We get
libxcb 1.1 as an update (or even just the specific change)?

The change file for libxcb 1.1 notes that in single threaded apps the locking
errors do not matter so it seems unreasonable to prevent all of these apps from
running when they clearly ran fine before.

NB. I have found the rebuilt packages from one of the other bugs and it does fix
the issue and allow the client to run ok, but this needs resolving as an update.
Comment 1 Laurence Vanek 2007-11-24 14:53:13 EST
I believe they have implemented the "sloppy lock" approach.


Comment 2 Tom Horsley 2007-11-26 09:51:39 EST
Actually, the ICA client is NOT multithreaded, so it can't possibly be written
in a non-threadsafe fashion. The asserts have got to be busted if they are
asserting in a non threaded program. This has got to be a libxcb bug at least
some of the time. I agree with the comment above about single threaded apps :-).
Comment 3 Kevin DeKorte 2007-11-27 10:42:22 EST
Please upgrade libxcb to 1.1 so that the environment variable
LIBXCB_ALLOW_SLOPPY_LOCK=1 can be set and recognized. I have this same problem
with Lotus Notes 8 on Linux and eclipse and java and Websphere Everyplace Client
6. Upgrading my machine from source and setting the environment variable stopped
all the crashes in these apps.
Comment 4 Nic Doye 2007-12-09 08:59:24 EST
Also see bug 397241 which lists other software that suffers because of this:

Sun Java 5
Sun Java 6

(both versions of Java trigger this with Eclipse and Netbeans).

If I could change the priority of this bug, I would.
Comment 5 Edward Rudd 2007-12-11 11:45:12 EST
libxcb-1.0-4.fc8 has been release, see if that update fixes this issue.
Comment 6 Matěj Cepl 2008-01-10 07:48:06 EST

*** This bug has been marked as a duplicate of 390261 ***

Note You need to log in before you can comment on or make changes to this bug.