Bug 39189 - linuxconf-web access locks up, looks related to xinetd
linuxconf-web access locks up, looks related to xinetd
Status: CLOSED DUPLICATE of bug 23560
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-05 01:55 EDT by Tim
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-08 00:41:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim 2001-05-05 01:55:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)

Description of problem:


How reproducible:
Always

Steps to Reproduce:
1.  Allow linuxconf-web access via xinetd (i.e., edit/reload "/etc/xinetd.d/linuxweb-conf").
2.  Use your web browser to access linuxconf (i.e., "lynx http://localhost:98").
3.  Select START.
4.  Enter username/password combo.
5.  Select NETWORKING under CONFIG.
6.  Select LINUXCONF NETWORK ACCESS under MISC.
7.  Do something (e.g., Select ENABLE NETWORK ACCESS).
8.  Select ACCEPT.



Actual Results:  1. An alert pops up (Under Netscape, it's "The document contained no data.  Try again later, or contact the server's 
administrator").
2. Try selecting ACCEPT again and another alert pops up (Under Netscape, "Netscape is unable to locate the server localhost:98, Please 
check the server name and try again".
3.  Linuxconf-web will no longer respond to requests (The above error on [2] on the line above pops up) until you restart/reload xinetd (i.e., 
"/etc/rc.d/init.d/xinetd reload").

Expected Results:  Linuxconf-web should have accepted the option and continued working.

Additional info:  It doesn't matter what you select really.  Once you hit an ACCEPT button, linuxconf-web stops responding.
Comment 1 Trond Eivind Glomsrxd 2001-05-07 17:11:58 EDT

*** This bug has been marked as a duplicate of 23560 ***
Comment 2 Tim 2001-05-08 00:41:27 EDT
The fix listed on bug #23560 listed below does *NOT* fix the problem; that is the problem *STILL* exists even after upgrading xinetd as indicated below:

*****
------- Additional comments from teg@redhat.com 2001-04-10 18:21:52 -------

 The release with the fix is xinetd-2.1.8.9pre14-7, coming soon to Rawhide and
 available now from http://people.redhat.com/teg/xinetd/
*****
Comment 3 Trond Eivind Glomsrxd 2001-05-08 10:34:20 EDT
Yes, it does. If you're still having problems, you probably haven't enabled it
in the config file (/etc/xinetd.d/linuxconf-web) and inside linuxconf (or there
are other setup issues, like firewalls or other access control mechanisms).

*** This bug has been marked as a duplicate of 23560 ***

Note You need to log in before you can comment on or make changes to this bug.