Bug 391951 - [NetApp 5.2 bug] root on multipath (iSCSI) not supported in Anaconda
[NetApp 5.2 bug] root on multipath (iSCSI) not supported in Anaconda
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: David Cantrell
Alexander Todorov
: OtherQA
Depends On:
Blocks: 217208 428723
  Show dependency treegraph
 
Reported: 2007-11-20 06:44 EST by Ritesh Raj Sarraf
Modified: 2009-06-19 21:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:32:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda iscsi multipath patch (418 bytes, patch)
2007-11-20 07:01 EST, nandkumar mane
no flags Details | Diff
iscsi mkinitrd patch (1.20 KB, patch)
2008-01-13 14:19 EST, nandkumar mane
no flags Details | Diff
mkinitrd patch for root on multipath(iscsi) feature (1.20 KB, patch)
2008-03-12 08:23 EDT, nandkumar mane
no flags Details | Diff

  None (edit)
Description Ritesh Raj Sarraf 2007-11-20 06:44:23 EST
Description of problem:


Version-Release number of selected component (if applicable):
Anaconda, the installer shipped with RHEL5 U1 supports root on multipath 
installation. It also supports iSCSI device discovery.
But it doesn't support the iSCSI devices to be listed as multipathed devices and thus 
limits a "root on multipath - iSCSI" solution.

How reproducible:
Very Reproducible

Steps to Reproduce:
1. Run the installation
2. Discover the iSCSI devices
3. Go to the disk list.
4. iSCSI devices are not listed as multipathed devices 

Actual results:
iSCSI devices aren't listed as multipathed devices even though they have multiple 
paths available.

Expected results:
When iSCSI devices are discovered and available with multiple paths, anaconda 
should list them as multipathed devices and allow installation on them.

Additional info:
Comment 1 nandkumar mane 2007-11-20 07:01:09 EST
Created attachment 264841 [details]
anaconda iscsi multipath patch

Attached is a patch which fixes the problem described above. We are able to see
iSCSI devices as multipathed devices and do a root installation on an iSCSI
multipathed device.

But it introduces a new problem. On reboot, the kernel panics because it can't
find the multipathed device. From the logs on the screen, we found that the
network and iSCSI services never started when executing in initrd. Looks like
the post-installation of anaconda is screwing up something.

But a normal iSCSI device based installation is proper and a working initrd
image is generated.

We need help in understanding how anaconda generates the initrd image and what
all dependencies are involved in it.
Any help/pointers will be appreciated.
Comment 2 nandkumar mane 2007-11-26 02:43:55 EST
Adding andrius and coughlan to cc list.
Comment 3 Ritesh Raj Sarraf 2007-12-06 02:23:33 EST
Can we have some feedback on this patch?

We'd like to see iSCSI root on multipath support in RHEL5.2.

With this patch applied, anaconda will be able to list iSCSI devices as multipathed 
devices and proceed with installation of '/' on an iSCSI LUN.
Comment 5 David Cantrell 2007-12-18 13:58:42 EST
(In reply to comment #1)
> Created an attachment (id=264841) [edit]
> anaconda iscsi multipath patch
> 
> Attached is a patch which fixes the problem described above. We are able to see
> iSCSI devices as multipathed devices and do a root installation on an iSCSI
> multipathed device.
> 
> But it introduces a new problem. On reboot, the kernel panics because it can't
> find the multipathed device. From the logs on the screen, we found that the
> network and iSCSI services never started when executing in initrd. Looks like
> the post-installation of anaconda is screwing up something.
> 
> But a normal iSCSI device based installation is proper and a working initrd
> image is generated.
> 
> We need help in understanding how anaconda generates the initrd image and what
> all dependencies are involved in it.
> Any help/pointers will be appreciated.

The patch provided seems to only address half of the problem, which you point
out.  The root multipath support in RHEL 5.1 is implemented in anaconda for
installation support and also in mkinitrd for initrd.img image generation.

For iSCSI root multipath support, you'll need to also check the mkinitrd package
and patch as necessary to complete the support.

In the mkinitrd SRPM for RHEL 5.1, you'll find this patch:

mkinitrd-5.1.19.6-multipath.patch

That's all of the root multipath work.  We'll probably need to modify the device
gathering functions so we write out the correct nash script to bring the system up.
Comment 6 nandkumar mane 2008-01-13 14:19:06 EST
Created attachment 291510 [details]
iscsi mkinitrd patch

Attached is a patch which solves the initrd image corruption issue. Now we are
able to see multipathed device as a root.

Previous anaconda attachment( attachment id=264841 (comment #1)) had solved
installation issue over multipathed device. But it had introduced new problem.
On reboot, the kernel panics because it can't find the multipathed device.

Here anaconda post installation was screwing up initrd image, only in case of
multipathed device.

mkinitrd patch makes sure that multipathed devices get handled properly.
Comment 7 David Cantrell 2008-01-14 15:26:00 EST
These patches look good.  I'm cloning this bug for mkinitrd since we need the
second patch to go in to that component.
Comment 9 nandkumar mane 2008-01-21 09:55:47 EST
Thanks David.
Can we have update on this bug?




Comment 11 Tom Coughlan 2008-02-12 13:24:26 EST
(In reply to comment #9)
> Thanks David.
> Can we have update on this bug?

The anaconda patch in comment #1 is included in the 5.2 beta release. 

The mkinitrd patch in comment #6 is also in, but that is tracked by BZ 428723,
since it is a different component. 

Comment 12 Alexander Todorov 2008-02-20 12:12:11 EST
NetApp,
can you verify that the fix is included in anaconda and it works? 

Thanks!
Comment 13 Ritesh Raj Sarraf 2008-02-20 17:06:17 EST
Thank you.
Will do once the betas are released.
Comment 14 Ritesh Raj Sarraf 2008-02-20 17:11:58 EST
Is there any other channel to get early access to the packages committed for 
RHEL5.2?

I've been tracking the Anaconda git archive at Fedora but I don't see the changes 
there.
Comment 16 Alexander Todorov 2008-03-12 05:58:39 EDT
NetApp,
as RHEL 5.2 beta is out now can you please verify if this issue is fixed.

Thanks
Comment 17 nandkumar mane 2008-03-12 08:23:11 EDT
Created attachment 297753 [details]
mkinitrd patch for root on multipath(iscsi) feature

anaconda patch has been included in 5.2 Beta.(works fine).

Though mkintrd patch has been included in mkintrd src, it doesn't apply during
package building. The switch (-p0) was supposed to be used to apply the patch
cleanly.
Attached is the same patch with the -p1 option.
Comment 19 Tom Coughlan 2008-03-14 16:36:08 EDT
Yes, this is a problem. I have moved the problem report to BZ 428723, though,
because that is the BZ for the mkinitrd patch. This one is for Anaconda.
Comment 20 John Poelstra 2008-03-20 23:56:19 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot1--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 21 nandkumar mane 2008-03-24 06:52:10 EDT
mkinitrd patch has not been included in RHEL 5.2 Snapshot1.
Comment 22 nandkumar mane 2008-03-24 06:54:34 EDT
Patch from Comment #17 is the valid patch for the mkinitrd problem.
Comment 23 Andrius Benokraitis 2008-03-24 08:59:55 EDT
Setting back to ON_QA becuase the issue found in Comment #21 has moved to bug
428723.
Comment 24 John Poelstra 2008-04-02 17:37:47 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 25 Brock Organ 2008-04-09 15:12:12 EDT
verified anaconda patch is present in anaconda-11.1.2.111-1 ...
also verified the patch for bug 428723 is present in mkinitrd-5.1.19.6-28 ... 

do we have any results from our partner that the multipath behavior is verified?

Comment 26 Ritesh Raj Sarraf 2008-04-09 18:24:22 EDT
The fix is included in the latest snapshot of RHEL5.2 and has been verified.

With this patch in place, iSCSI devices are listed as multipathed devices and
installation on those devices occurs properly.
Comment 27 John Poelstra 2008-04-09 18:43:54 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot4--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 29 Kostas Georgiou 2008-05-13 08:14:03 EDT
I have a requirement to use iscsi root multipath and during some testing with
the anaconda patch (under 5.1) I am not sure that it is complete. 

* anaconda doesn't mark the root device as _netdev 
  it should be _rnetdev after5.2 though.
* I was unable to use lvm with it under ks
  part pv.00 --size=14000 --grow --ondevice=mapper/mpath0 fails
  but this could be because I have no idea on how the multipath kickstart
command works and I was unable to find any docs for it.
Comment 31 nandkumar mane 2008-05-14 03:27:36 EDT
Yeah. I agree with your first point. Currently anaconda is not marking root 
multipath device as _netdev. Will fix this in 5.3.
Comment 32 errata-xmlrpc 2008-05-21 11:32:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.