Bug 428723 - [NetApp 5.2 bug] root on multipath (iSCSI) not supported in mkinitrd
[NetApp 5.2 bug] root on multipath (iSCSI) not supported in mkinitrd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.1
All Linux
high Severity high
: rc
: ---
Assigned To: Peter Jones
Alexander Todorov
: OtherQA, Reopened
Depends On: 391951
Blocks: 217208
  Show dependency treegraph
 
Reported: 2008-01-14 15:28 EST by David Cantrell
Modified: 2009-06-19 22:04 EDT (History)
11 users (show)

See Also:
Fixed In Version: RHBA-2008-0437
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:26:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
netapp-mkinitrd.patch (1.20 KB, patch)
2008-01-14 15:28 EST, David Cantrell
no flags Details | Diff
mkintrd patch for root on multipath(iscsi) support (1.20 KB, patch)
2008-03-24 16:05 EDT, nandkumar mane
no flags Details | Diff
mkinitrd patch for complete root on multipath(iscsi) support (2.49 KB, patch)
2008-04-10 10:29 EDT, nandkumar mane
no flags Details | Diff

  None (edit)
Comment 1 David Cantrell 2008-01-14 15:28:26 EST
Created attachment 291627 [details]
netapp-mkinitrd.patch
Comment 3 RHEL Product and Program Management 2008-01-14 15:35:15 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Peter Jones 2008-01-31 18:21:19 EST
The patch is applied in mkinitrd-5.1.19.6-20 .
Comment 9 Tom Coughlan 2008-03-14 16:32:56 EDT
There is a report in Bug 391951 indicating that:

"Though mkintrd patch has been included in mkintrd src, it doesn't apply during
package building. The switch (-p0) was supposed to be used to apply the patch
cleanly.

Sure enough:

rpmbuild ... 

Patch #15 (mkinitrd-5.1.19.6-bz428723-iscsi-mpath.patch):
+ patch -p1 -s
missing header for unified diff at line 3 of patch

An alternate patch that uses the -P1 option is provided there. 

I am moving this BZ to FAILS_QA, since this is the mkinitrd BZ. (The other BZ is
for the related Anaconda issue.) 
Comment 10 nandkumar mane 2008-03-24 06:57:09 EDT
The patch mentioned in Comment #17 in Bugzilla #391951 needs to be applied to 
fix this bug. The correct patch is not yet applied to RHEL5 U2 Snapshot1
Comment 11 Andrius Benokraitis 2008-03-24 09:27:47 EDT
The patch you are referring to looks identical to what has already been
committed to the RHEL 5.2 tree, as shown in this bug, Comment #1.
Comment 13 Andrius Benokraitis 2008-03-24 11:33:34 EDT

*** This bug has been marked as a duplicate of 368821 ***
Comment 14 Peter Jones 2008-03-24 13:16:07 EDT
I was wrong on IRC, this is not actually a dupe.
Comment 15 Ritesh Raj Sarraf 2008-03-24 14:46:56 EDT
(In reply to comment #11)
> The patch you are referring to looks identical to what has already been
> committed to the RHEL 5.2 tree, as shown in this bug, Comment #1.

Yes, the patch is identical. The problem was that the patch was generated incorrectly.
The earlier patch required the -p0 switch to apply clean whereas the convention has been to use -p1 
switch. That's why, even though the patch is currently committed, doesn't work.

The new patch is a revision of the same patch with the proper (-p1) switch.
Comment 16 Ritesh Raj Sarraf 2008-03-24 14:49:20 EDT
Nandkumar,
Can you please attach the same patch to this bugzilla ?
Comment 17 nandkumar mane 2008-03-24 16:05:40 EDT
Created attachment 298937 [details]
mkintrd patch for root on multipath(iscsi) support

Though mkintrd patch has been included in mkintrd src, it doesn't apply during
package building. The switch (-p0) was supposed to be used to apply the patch
cleanly.
Attached is the same patch with the -p1 option.
Comment 19 Peter Jones 2008-03-26 16:25:10 EDT
Fixed in 5.1.19.6-27 .
Comment 21 John Poelstra 2008-04-02 17:37:48 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 22 Brock Organ 2008-04-09 15:08:07 EDT
verified the patch is present in mkinitrd-5.1.19.6-28 ... 

do we have any results from our partner that the multipath behavior is verified?
Comment 23 Ritesh Raj Sarraf 2008-04-09 18:28:51 EDT
The patch in comment #17 has been included in the latest snapshot of RHEL 5.2
This has been verified. With this, we have a working initrd image in place 
which supports iSCSI Multipathed root installations.

We though have a minor problem. We've noticed that when iSCSId is run, the 
login takes place only to a single target address. This leads to the root LUN 
having just a single path.
Later when init is run, and iSCSId is re-executed, it is able to login to the 
additional targets and thus provide multiple paths to the LUN.

We've working on the fix and would be posting a patch soon.
Comment 24 John Poelstra 2008-04-09 18:43:55 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot4--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 25 Alexander Todorov 2008-04-10 04:48:13 EDT
(In reply to comment #23)
> The patch in comment #17 has been included in the latest snapshot of RHEL 5.2
> This has been verified. With this, we have a working initrd image in place 
> which supports iSCSI Multipathed root installations.
> 
> We though have a minor problem. We've noticed that when iSCSId is run, the 
> login takes place only to a single target address. This leads to the root LUN 
> having just a single path.
> Later when init is run, and iSCSId is re-executed, it is able to login to the 
> additional targets and thus provide multiple paths to the LUN.
> 
> We've working on the fix and would be posting a patch soon.

Hello Ritesh,
is the problem you describe a separate issue or it's caused by the patch to
initrd? If it is a separate issue can you please file another bug?

Thanks.
Comment 26 nandkumar mane 2008-04-10 10:29:47 EDT
Created attachment 301995 [details]
mkinitrd patch for complete root on multipath(iscsi) support

Attaching a patch which will resolve problem mentioned in comment #23.

Previous patch (id=298937) makes sure that system will reboot properly after
doing installation on multipathed device. We though have a minor problem. We've
noticed that when iSCSId through initrd is run, the login takes place only to a
single target address. This leads to the root LUN having just a single path.
Later when init is run, and iSCSId is re-executed, it is able to login to the 
additional targets and thus provide multiple paths to the LUN.

Attached patch makes sure that logins to all paths will happen when iscsid
through initrd is run.

It would be great if you could provide us with a build package of mkinitrd
before snap5 so that we can test further.
Comment 27 nandkumar mane 2008-04-10 10:44:00 EDT
Hi Alexander,

Initially we had no support for multipathd(iscsi) devices in mkinitrd. Patch 
(id=298937) added support for the same but it wasn't complete. Patch 
(id=301995) adds complete support for multipathd(iscsi) devices in mkinitrd.

So we don't need to create seprate bugzilla for this.

Thank you
Comment 31 John Poelstra 2008-04-11 17:45:18 EDT
changing to ASSIGNED
Comment 33 Denise Dumas 2008-04-14 14:19:49 EDT
This is too much potential de-stabilization for 5.2 at thispoint (snapshot 6 out
of 8). We'll have to finish this up in 5.3.
Comment 34 Andrius Benokraitis 2008-04-14 14:24:25 EDT
NetApp: Please create a new bugzilla to track this in 5.3.
Comment 35 nandkumar mane 2008-04-15 03:13:33 EDT
New patch will not bring de-stabilization for 5.2 as the patch doesn't make 
any change in the code for iscsi block devices. It does changes only for a 
multipathd device.

We are keeping iscsi code intact (which was already there). Changes will be 
only in newly added code which is for the multipathed devices.

If would be great if we can include this in 5.2.
Comment 36 Andrius Benokraitis 2008-04-21 09:31:55 EDT
Hi - this still needs a new bugzilla for 5.3.
Comment 37 John Poelstra 2008-04-23 13:38:56 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot6--available now on partners.redhat.com.  

We are nearing GA for 5.2 so please test and confirm that your issue is fixed ASAP.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 38 Alexander Todorov 2008-04-30 03:47:17 EDT
Hello NetApp,
can you update us on the status of this issue? 

Thanks.
Comment 39 nandkumar mane 2008-04-30 09:08:38 EDT
The patch updated in Comment #26 has not been updated in latest mkinitrd 
package. As per Adrius(Comment #36), we need to file new bugzilla for 5.3.
Comment 40 John Poelstra 2008-05-01 12:49:18 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot7--available now on partners.redhat.com.  

We are nearing GA for 5.2--this is the last opportunity to test and confirm that
your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 41 James Laska 2008-05-02 14:08:53 EDT
Thank you for the test feedback in comment#23.  Moving this bug to VERIFIED
based on your comments.

The additional issue mentioned will need to be filed against RHEL5.3.

Many thanks!
Comment 43 errata-xmlrpc 2008-05-21 11:26:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0437.html

Note You need to log in before you can comment on or make changes to this bug.