Bug 392271 - Review Request: perl-Perl-MinimumVersion - Find a minimum required version of perl
Review Request: perl-Perl-MinimumVersion - Find a minimum required version ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 392291 729601
  Show dependency treegraph
 
Reported: 2007-11-20 08:37 EST by Ralf Corsepius
Modified: 2012-04-04 23:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.15.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 23:00:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tibbs: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2007-11-20 08:37:20 EST
Spec URL: ftp://packman.links2linux.de/pub/packman/fedora/SRPMS/perl-Perl-MinimumVersion.spec
SRPM URL: ftp://packman.links2linux.de/pub/packman/fedora/SRPMS/perl-Perl-MinimumVersion-0.15-1.fc8.src.rpm
Description: Find a minimum required version of perl for Perl code

This package is a new dependency of other packages already in Fedora
Comment 1 Jason Tibbitts 2007-11-20 15:40:26 EST
* source files match upstream:
   d832d97f092976e8456460db1afe02be31505582211e912e256d4c8784ecec5f  
   Perl-MinimumVersion-0.15.tar.gz
* package meets naming and versioning guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
* summary is OK.
* description is OK.
* dist tag is present.
* build root is OK.
* license field matches the actual license.
* license is open source-compatible.
* license text included in package.
* latest version is being packaged.
* BuildRequires are proper.
* %clean is present.
* package builds in mock (rawhide, x86_64).
* package installs properly
* rpmlint is silent.
* final provides and requires are sane:
   perl(Perl::MinimumVersion) = 0.15
   perl-Perl-MinimumVersion = 0.15-1.fc9
  =
   /usr/bin/perl
   perl >= 0:5.005
   perl(:MODULE_COMPAT_5.8.8)
   perl(Carp)
   perl(File::Find::Rule)
   perl(Getopt::Long)
   perl(List::Util)
   perl(PPI)
   perl(PPI::Util)
   perl(Params::Util)
   perl(Perl::MinimumVersion)
   perl(base)
   perl(constant)
   perl(strict)
   perl(vars)
   perl(version)

* %check is present and all tests pass:
   All tests successful.
   Files=4, Tests=63,  1 wallclock secs ( 0.49 cusr +  0.09 csys =  0.58 CPU)
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
* no scriptlets present.
* code, not content.
* documentation is small, so no -docs subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.

APPROVED
Comment 2 Ralf Corsepius 2007-11-21 00:34:22 EST
New Package CVS Request
=======================
Package Name: perl-Perl-MinimumVersion
Short Description: Find a minimum required version of perl for Perl code
Owners: corsepiu
Branches: F-8 F-7
InitialCC: fedora-perl-devel-list@redhat.com
Cvsextras Commits: yes
Comment 3 Jason Tibbitts 2007-11-21 13:29:33 EST
CVS done.
Comment 4 Ralf Corsepius 2007-11-28 23:00:41 EST
Packages pushed and released for FC-7, FC-8 and rawhide.
Comment 5 Paul Howarth 2012-03-14 08:20:15 EDT
Package Change Request
======================
Package Name: perl-Perl-MinimumVersion
New Branches: EL-5
Owners: pghmcfc
InitialCC: perl-sig

Ralf has previously declared his non-interest in EPEL, which is why I am
requesting this branch myself.
Comment 6 Jon Ciesla 2012-03-14 08:24:35 EDT
Git done (by process-git-requests).
Comment 7 Fedora Update System 2012-03-18 11:06:38 EDT
perl-Perl-MinimumVersion-1.20-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-Perl-MinimumVersion-1.20-2.el5
Comment 8 Fedora Update System 2012-04-04 23:05:20 EDT
perl-Perl-MinimumVersion-1.20-3.el5 has been pushed to the Fedora EPEL 5 stable repository.

Note You need to log in before you can comment on or make changes to this bug.