Bug 729601 - perl-Test-MinimumVersion imported but not built for EL5
Summary: perl-Test-MinimumVersion imported but not built for EL5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Test-MinimumVersion
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 251128 392261 392271 463711 803301 803307 803340
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 10:36 UTC by Xavier Bachelot
Modified: 2012-04-05 03:03 UTC (History)
2 users (show)

Fixed In Version: perl-Test-MinimumVersion-0.011-2.1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-05 03:03:52 UTC


Attachments (Terms of Use)

Description Xavier Bachelot 2011-08-10 10:36:39 UTC
Description of problem:
perl-Test-MinimumVersion was imported but not built for EL5. Could you please build and push it, I need it for another package.

Thanks,
Xavier

Comment 1 Paul Howarth 2012-03-14 12:22:10 UTC
There are a bunch of dependencies that need sorting out before this can be built, but I'm working on it:

 * perl-Probe-Perl needs branching and building for EPEL-5 (Bug #463711)
 * perl-Test-Script needs branching and building for EPEL-5 (Bug #251128)
 * perl-PPI needs updating to ≥ 1.201 (Bug #803301)
 * perl-Params-Util needs updating to ≥ 0.38 (Bug #803307)
 * perl-File-Find-Rule-Perl needs branching and building for EPEL-5 (Bug #392261)
 * perl-Perl-MinimumVersion needs branching and building for EPEL-5 (Bug #392271)

Comment 2 Paul Howarth 2012-03-14 13:45:31 UTC
And another one:

 * perl-YAML-Tiny needs updating to ≥ 1.40 (Bug #803340)

Comment 3 Paul Howarth 2012-03-18 15:11:51 UTC
(In reply to comment #2)
> And another one:
> 
>  * perl-YAML-Tiny needs updating to ≥ 1.40 (Bug #803340)

Actually the EL-6 package that I'm basing the EPEL-5 one on does not require this.

perl-Test-MinimumVersion is going to land in EPEL-5 later today, and I'll be adding a buildroot override for it so that it can be used for builds before it's been through the two-week period in epel-testing.

Comment 4 Fedora Update System 2012-03-18 17:09:20 UTC
perl-Test-MinimumVersion-0.011-2.1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-Test-MinimumVersion-0.011-2.1.el5

Comment 5 Paul Howarth 2012-03-18 18:58:57 UTC
The buildroot override for perl-Test-MinimumVersion is now in place and I'll leave it there until the package is pushed to stable, so you can now BuildRequire: perl(Test::MinimumVersion) in your EPEL-5 packages.

Comment 6 Fedora Update System 2012-03-19 20:00:47 UTC
perl-Test-MinimumVersion-0.011-2.1.el5 has been pushed to the Fedora EPEL 5 testing repository.

Comment 7 Fedora Update System 2012-04-05 03:03:52 UTC
perl-Test-MinimumVersion-0.011-2.1.el5 has been pushed to the Fedora EPEL 5 stable repository.


Note You need to log in before you can comment on or make changes to this bug.