Bug 393201 - Missing awk in vfs scripts
Missing awk in vfs scripts
Status: CLOSED DUPLICATE of bug 381751
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-20 16:25 EST by Charlie Moschel
Modified: 2013-07-02 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-21 04:57:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Charlie Moschel 2007-11-20 16:25:24 EST
Description of problem:
Actual 'awk' text in the external vfs scripts is missing, causing many vfs 
types to fail (at least lslr, ualz, uarj, uha, ulha, urar, and uzoo).

Version-Release number of selected component (if applicable):
F8 and development. F6 is OK, didn't check F7

How reproducible:

Steps to Reproduce: (using rar as an example)
1.Install F8 
2.Install mc, urar (or rar)
3.Open mc, try to open a rar (or other type listed above)
Actual results:
Smth like: "-v: command not found"

Expected results:
mc pane with rar archive contents

Additional info:

Looks like awk was not found when 'configure' was run during RPM build.
IE, in /usr/share/mc/extfs/urar, we have for F6:
$UNRAR v -c- "$1" | gawk -v uid=`id -u` -v gid=`id -g` '

In F8, we have:
$UNRAR v -c- "$1" |  -v uid=`id -u` -v gid=`id -g` '

Note missing gawk command.

Is awk considered part of a minimal Fedora install?  Other extfs scripts use 
perl or sed.  If we don't want to require awk, maybe time to look again at bz 
223726, suggesting splitting mc extfs into a separate package.
Comment 1 Jindrich Novy 2007-11-21 04:57:15 EST
Yes, update to F8 which fixes this was pushed yesterday. Thanks for the
description and investigation though!

The bug was introduces when experiments with minimal buildroot contents were
made and gawk was erroneously excluded from the minimal list. gawk is back again

*** This bug has been marked as a duplicate of 381751 ***

Note You need to log in before you can comment on or make changes to this bug.