This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 393651 - nm-applet crashes when plugging a WM6-based PDA to USB
nm-applet crashes when plugging a WM6-based PDA to USB
Status: CLOSED DUPLICATE of bug 337191
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 00:46 EST by Alexey Neyman
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 02:28:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexey Neyman 2007-11-21 00:46:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.8 (like Gecko)

Description of problem:
Plugging in a Windows Mobile 6 PDA (E-TEN Glofiish X500+) results in a crash 
of the NetworkManager. This happens both with the default kernel and with a 
custom-built kernel with the patch from SynCE applied to rndis_host module. 
Just before dying, NM displays a "You're connected to a wired network" 
balloon.

Relevant portion of dmesg output:

usbcore: registered new interface driver cdc_ether
usbcore: registered new interface driver rndis_host
usb 2-1: new full speed USB device using uhci_hcd and address 3
usb 2-1: configuration #1 chosen from 1 choice
eth2: register 'rndis_host' at usb-0000:00:1d.0-1, RNDIS device, 
80:00:60:0f:e8:00
eth2: no IPv6 routers present
nm-applet[3314]: segfault at 00000000 eip 00958bc8 esp bfb96c7c error 4


Version-Release number of selected component (if applicable):
0.7.0-0.5.svn3030.fc8

How reproducible:
Always


Steps to Reproduce:
1. Plug the PDA (tried only with E-TEN Glofiish X500+, but suspect that any 
activation of rndis_host interface will trigger it).
2. See the networkmanager applet go away, look at dmesg to confirm that it 
crashed.

Actual Results:


Expected Results:


Additional info:
Comment 1 Dan Williams 2007-11-21 02:28:10 EST

*** This bug has been marked as a duplicate of 337191 ***

Note You need to log in before you can comment on or make changes to this bug.