This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 337191 - nm-applet crash HAL device
nm-applet crash HAL device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 360661 393651 (view as bug list)
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-18 02:10 EDT by Damien Covey
Modified: 2007-12-03 00:35 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.7.0-0.6.6.svn3109.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 00:35:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Bug Report (1.33 KB, text/plain)
2007-10-31 13:35 EDT, Klaus Möllenhoff
no flags Details

  None (edit)
Description Damien Covey 2007-10-18 02:10:59 EDT
Description of problem:
nm-applet crashes when my SonyEricsson w810i is pluged into USB

Version-Release number of selected component (if applicable):
0.7.0

How reproducible:
Every time phone is pluged in and I click on the applet icon in sys-tray

Steps to Reproduce:
1.Plug SonyEricsson w810i into USB
2.Click nm-applet tray icon
  
Actual results:
Crash - bug report tool opens

Expected results:
List of  networks is shown

Additional info:
Console output of nm-applet when crash occurs.

** (nm-applet:3450): WARNING **: Error getting vendor info from HAL: No property
info.vendor on device with id
/org/freedesktop/Hal/devices/usb_device_fce_d038_3524010190558740_if8
52cbb633-f0bd-fcfa-46cc2c88-29a433de is dumped
Comment 1 Klaus Möllenhoff 2007-10-31 13:35:50 EDT
Created attachment 244751 [details]
Bug Report
Comment 2 Klaus Möllenhoff 2007-10-31 13:36:34 EDT
i have the same problem, but not with pluged in phone.

every time i click on nm-applet it crashes.

in the attachement is the created bug report
Comment 3 Dan Williams 2007-10-31 13:54:36 EDT
*** Bug 360661 has been marked as a duplicate of this bug. ***
Comment 4 Damien Covey 2007-10-31 18:24:52 EDT
Judging by your attachment and my console output it looks like it has to do with
NM not handling HAL devices that don't have an "info.vendor' property. 
To me it looks like
"/org/freedesktop/Hal/devices/usb_device_ace_1211_noserial_if0" is a USB device
on your system that has no "info.vendor", if you try unplugging all USB devices
and clicking nm-applet perhaps you can find the offender.
Still, I'd say NM (or hal) has to be patched to handle this.
Comment 5 Dan Williams 2007-10-31 18:28:45 EDT
Fixed in upstream SVN FWIW.  Turns out that HAL changed recently so that the
net.physical_device of the network interface doesn't have the product & vendor
IDs, but the net.physical_device's parent does.  So I've committed code that
walks up the tree up to the parent of the net.physical_device of the network
interface and grabs product & vendor info from that.  Additionally, it is now
smarter about what it displays as the device description, and I fixed the actual
bug where the applet was crashing when the product or vendor info was NULL.
Comment 6 Damien Covey 2007-10-31 18:33:40 EDT
Sounds great.  Any idea if this is going to make it into Fedora 8 ?
Comment 7 Dan Williams 2007-11-01 07:26:12 EDT
Will try to; can't guarantee that.
Comment 8 Klaus Möllenhoff 2007-11-03 14:42:30 EDT
how does it look like? is it going to be fixed in f8?
Comment 9 Dan Williams 2007-11-03 15:30:28 EDT
going to be in a 0-day update to F8
Comment 10 Klaus Möllenhoff 2007-11-09 06:45:32 EST
it isnt still working for me...
Comment 11 Dan Williams 2007-11-09 14:50:09 EST
an update for F8 hasn't been pushed yet since I'm still getting the cert issues
fixed.
Comment 12 Klaus Möllenhoff 2007-11-14 09:55:00 EST
hi

when do you think you are able to push an update?
Comment 13 Dan Williams 2007-11-21 02:28:10 EST
*** Bug 393651 has been marked as a duplicate of this bug. ***
Comment 14 Alexey Neyman 2007-11-21 02:46:11 EST
I am not sure #393651 is a duplicate; I didn't have to click anything to make 
nm-applet crash. Anyway, will retry once this one is fixed. Any chance for 
that to happen any time soon?
Comment 15 Fedora Update System 2007-11-28 20:44:06 EST
NetworkManager-0.7.0-0.6.6.svn3109.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'
Comment 16 Klaus Möllenhoff 2007-11-30 14:08:12 EST
its working for me!
Comment 17 Fedora Update System 2007-12-03 00:35:45 EST
NetworkManager-0.7.0-0.6.6.svn3109.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.