Bug 39423 - multiple -HUP should not be delivered
multiple -HUP should not be delivered
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sysklogd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 47020 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-07 13:04 EDT by Need Real Name
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 23:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-07 13:04:03 EDT
Multiple -HUP to syslogd should not be delivered.

Currently /etc/logrotate.d/syslog 
delivers a -HUP for every file.

This is incorrect. It should use sharedscripts command
for example like one from /etc/logrotate.d/samba

Also see

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=34230

for a similar report with apache log rotation
Comment 1 Bill Nottingham 2001-07-05 23:14:55 EDT
*** Bug 47020 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2001-07-09 00:19:05 EDT
Added in 1.4.1-1, thanks!
Comment 3 Need Real Name 2001-07-09 00:55:57 EDT
 Very good it was fixed.
 Without this fix a race often caused sysklogd killed
 (when second -HUP gets delivered during first -HUP processing)
 This often happened with slow computers.

 To model such problem just do

 while true ; do killall -HUP sysklogd ;  done

 the sysklogd will get killed.
 Same thing did multiple -HUP from log rotation.
 Hopefully it will be fixed from now on in sysklogd.

 Also, check the other daemons for this type of problem.
 It is very annoying - server just dies one every one or two months.
 I found few (apache, exim, syslog)
 which now seems fixed. Check the other daemons to make sure 
 no multiple -HUP used for daemon restarting.

Note You need to log in before you can comment on or make changes to this bug.