Bug 394471 - Updater crashed. see bug report attached.
Updater crashed. see bug report attached.
Status: CLOSED DUPLICATE of bug 428323
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: John Matthews
Depends On:
  Show dependency treegraph
Reported: 2007-11-21 11:16 EST by Lewis Pannell
Modified: 2013-01-10 05:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-26 08:22:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lewis Pannell 2007-11-21 11:16:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20071018 Red Hat/ Firefox/

Description of problem:
Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 561, in applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 273, in downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 690, in downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 447, in getPackage
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5/getPackage/samba-common-3.0.25b-1.el5_1.2.i386.rpm
start: None
url: None
text: (2/13): samba-common-3.0.25b-1.el5_1.2.i386.rpm
self: rhel-i386-server-5
cache: True
reget: simple
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5
relative: getPackage/samba-common-3.0.25b-1.el5_1.2.i386.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), ('X-RHN-Auth', '8Dp4E19IJ0rhxiOCy7wMWA=='), ('X-RHN-Auth-Server-Time', '1195659492.19'), ('X-RHN-Server-Id', 1007484708))
checkfunc: (<bound method PackageUpdater.verifyPkg of <__main__.PackageUpdater object at 0x8a8abcc>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0xa060ccc>, 1), {})
copy_local: 0
end: None
local: //var/cache/yum/rhel-i386-server-5/packages/samba-common-3.0.25b-1.el5_1.2.i386.rpm

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:

Actual Results:

Expected Results:

Additional info:
Comment 1 Phil Knirsch 2007-11-21 11:57:29 EST
Reassigning to pirut component which fails here during an update.

Read ya, Phil
Comment 2 James Antill 2008-09-26 00:36:51 EDT
this is a known yhn-plugin bug, and is already fixed.
Comment 3 John Matthews 2008-09-26 08:22:16 EDT

*** This bug has been marked as a duplicate of bug 428323 ***

Note You need to log in before you can comment on or make changes to this bug.