Bug 395531 - [kn_IN] ra + halant + ra is not rendering properly
[kn_IN] ra + halant + ra is not rendering properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lohit-fonts (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Rahul Bhalerao
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 395561
  Show dependency treegraph
 
Reported: 2007-11-22 06:11 EST by Shankar Prasad
Modified: 2015-04-21 00:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 03:54:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Acrual and expected results (15.43 KB, image/png)
2007-11-22 06:11 EST, Shankar Prasad
no flags Details
patch for Lohit-Kannada.sfd (125.47 KB, patch)
2008-01-24 05:57 EST, Rahul Bhalerao
no flags Details | Diff
fixed ttf file (188.35 KB, application/x-font-ttf)
2008-01-24 05:58 EST, Rahul Bhalerao
no flags Details
r halant r with indepndent vowel (8.06 KB, image/png)
2008-01-24 08:40 EST, Shankar Prasad
no flags Details

  None (edit)
Comment 2 Rahul Bhalerao 2008-01-24 05:57:13 EST
Created attachment 292782 [details]
patch for Lohit-Kannada.sfd

This patch adds and extra glyph with appropriate ligature rule.
Comment 3 Rahul Bhalerao 2008-01-24 05:58:20 EST
Created attachment 292783 [details]
fixed ttf file

Shanky, can you please test this font file before I can build it for fedora?
Comment 4 Shankar Prasad 2008-01-24 08:40:07 EST
Created attachment 292797 [details]
r halant r with indepndent vowel

Rahul,
The fix works fine, but when I try combining with any other vowel (an example
is shown in the attachment) the error is reccurring back. This is same for all
the independent vowels(unicodes from 0c86 to 0c94.
Comment 5 Rahul Bhalerao 2008-04-02 03:54:04 EDT
This bug cannot be completely fixed in fonts due to limitations in the opentype
layout engines. Also if the below base form of Ra is required to be used in
Ra+Halant+RA kind of combination, it can be currently obtained with the use of
ZWJ as Ra+ZWJ+Halant+Ra. Thus this bug is not worth fixing in font.

Note You need to log in before you can comment on or make changes to this bug.