Bug 395561 - [kn_IN] ra + halant + ra is not rendering properly
[kn_IN] ra + halant + ra is not rendering properly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fonts-indic (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
QE Internationalization Bugs
:
Depends On: 395531
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 06:37 EST by Rahul Bhalerao
Modified: 2010-10-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 03:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Bhalerao 2007-11-22 06:37:41 EST
+++ This bug was initially created as a clone of Bug #395531 +++

Description of problem:
Following combination have problem with 'ra' shape in below base.
Please check one example for #27, and other are at
http://batman.brisbane.redhat.com/~indic/IndicTC/lang/kn_IN/font/IndicFontTestCaseGSUB-Kannada.html

#197- U+0CB0 U+0CCD U+0CB0  ರ್ರ  RA + HALANT + RA

Version-Release number of selected component (if applicable):
Tested with fonts-kannada-2.1.5-2.fc8


How reproducible:
Everytime

Steps to Reproduce:
1.Get into Kannada locale
2.Open any writer and activate SCIM
3.key-in jdj(iniscript) and see the output (ರ್ರ)
  
Actual results:
As in attached image

Expected results:
As in attached image

Additional info:

-- Additional comment from svenkate@redhat.com on 2007-11-22 06:11 EST --
Created an attachment (id=266671)
Acrual and expected results
Comment 2 Rahul Bhalerao 2008-04-02 03:55:19 EDT
This bug cannot be completely fixed in fonts due to limitations in the opentype
layout engines. Also if the below base form of Ra is required to be used in
Ra+Halant+RA kind of combination, it can be currently obtained with the use of
ZWJ as Ra+ZWJ+Halant+Ra. Thus this bug is not worth fixing in font.
Comment 3 Jens Petersen 2008-06-17 03:21:13 EDT
Okay thanks - unproposing and reversing devel ack.

Note You need to log in before you can comment on or make changes to this bug.