Bug 39644 - problems with gnome-terminal
Summary: problems with gnome-terminal
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 54084 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-08 13:38 UTC by Joachim Backes
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 13:51:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Backes 2001-05-08 13:38:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.4 i686)

Description of problem:
gnome-terminal displays german umlauts as blanks. The gnome-terminal from
RedHat 7.0 (included in gnome-core-1.2.1-33)  displays german umlauts
correctly.

How reproducible:
Always

Steps to Reproduce:
1. Start a gnome-terminal, and enter german umlauts.
2.
3.
	

Additional info:

Comment 1 Yue Shi Lai 2001-05-12 10:42:49 UTC
This behavior is related to (already reported) lack of internationalized menus
in GNOME.  It seems that without defining an LC_ALL environmental variable,
GNOME refuses to use the locale set by LANG.  This behavior is against the rules
set in XPG4 and POSIX.2 which defines the LANG to be the choice if LC_ALL is not
defined.  Therefore, the scripts /etc/profile.d/lang.sh (and .csh) adhere
correctly to the standard by undefining the LC_ALL variable if it is identical
to LANG.

There are many methods to circumvent the current situation:

1. Explicitly select "Deutsch" in the GDM menu (solves only the problem under X
environemnt).  In this case GDM set the LC_ALL variable.

_OR_

2. Add a line defining LC_ALL="de_DE" after the line with LANG="de_DE", then
edit the files /etc/profile.d/lang.sh by commenting out lines as follow (and
similarly with lang.csh):

    if [ -n "$LC_ALL" ]; then
#       if [ "$LC_ALL" != "$LANG" ]; then
         export LC_ALL
#       else
#         unset LC_ALL
#       fi
    else

This is not a recommended way to solve the problem, because it is important to
make GNOME compliant to XPG4 and POSIX.2.  It is possible is that Ximian's GNOME
1.4 has already solve this problems.

Comment 2 Havoc Pennington 2001-05-14 14:30:38 UTC
Re: umlauts, if you go into gnome-terminal preferences and turn off the "use
multibyte support" setting then it should work. Reopen the bug is not.

Re: LANG/LC_ALL, I believe this is handled entirely by the C library and
gettext(), GNOME isn't doing anything special. Anyway, you said it's being
tracked in another reported bug so I won't leave this bug open for that.

Comment 3 Yue Shi Lai 2001-05-14 22:03:24 UTC
I am not sure whether the C library is really the one to blame. Today, I have
installed the Ximian GNOME 1.4 (which does not update the C library). Now, even
without any LC_xxx set, the gnome-terminal is working properly. Unfortunately, I
am now unable to reproduce the problem (the terminal of GNOME 1.4 also does not
has a such option), may be backes@rhrk.uni-kl.de should try this again.

Comment 4 Havoc Pennington 2001-05-14 22:38:30 UTC
Ximian "fixes" the problem with umlauts by not having Japanese multibyte
support. Red Hat RPMs have a preference option; turn off "use multibyte" to get
the Ximian behavior. Red Hat is in Japanese mode by default.

Comment 5 Joachim Backes 2001-09-27 06:23:30 UTC
*** Bug 54084 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.