Bug 396931 - pirut infinite recursion
Summary: pirut infinite recursion
Status: CLOSED DUPLICATE of bug 375221
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-23 15:39 UTC by Daniel Wilcox
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 16:00:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the text given in the dialog box pirut brought up (124.25 KB, text/plain)
2007-11-23 15:39 UTC, Daniel Wilcox
no flags Details
pirut dump output (121.10 KB, application/octet-stream)
2007-11-25 19:12 UTC, Russell Harrison
no flags Details

Description Daniel Wilcox 2007-11-23 15:39:10 UTC
Description of problem:

I tried to install nvidia's Cg compiler, using its rpm package for RedHat, named
Cg-1.5_Sep2007.x86_64.rpm, and a dialog box comes up that says an unhandled
exception occurred that is most likely a bug.

The crash occurred while system-install-packages was loading the rpm file -
before I could click "Apply" or anything.

The stack trace appears to be repeating, thus I believe there is some kind of
infinite recursion.


Version-Release number of selected component (if applicable):
I'm not able to discover what version-release number of pirut is installed.


How reproducible:
Try to install Cg-1.5_Sep2007.x86_64.rpm


Steps to Reproduce:
1. Download Cg-1.5_Sep2007.x86_64.rpm from
http://developer.nvidia.com/object/cg_toolkit.html
2. Attempt to install the rpm
  

Actual results:
pirut crash


Expected results:
not a crash


Additional info:
I tried to re-download the rpm in case the first download was corrupted, but it
did not solve the issue.

Comment 1 Daniel Wilcox 2007-11-23 15:39:10 UTC
Created attachment 267631 [details]
the text given in the dialog box pirut brought up

Comment 2 Russell Harrison 2007-11-25 19:12:37 UTC
Created attachment 268301 [details]
pirut dump output

Comment 3 Russell Harrison 2007-11-25 19:15:22 UTC
I think I'm seeing the same problem.  It may be related to using the version
lock yum plugin.  When I run system-install-packages from the command line I see
"Reading version lock configuration" repeated over and over before I get the
same crash.  Disabling the versionlock plugin makes the problem go away.

Comment 4 Jeremy Katz 2007-11-26 16:00:27 UTC

*** This bug has been marked as a duplicate of 375221 ***


Note You need to log in before you can comment on or make changes to this bug.