Bug 39706 - Empty fonts.dir for local fonts
Empty fonts.dir for local fonts
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 43562 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 14:18 EDT by Sammy
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 23:47:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-05-08 14:18:35 EDT
Description of Problem:

I have created some font directories in /usr/lib/X11/fonts that hold my
Type1 fonts. I did this to always have fonts that come with XFree86
distribution not mix with what I have. The problem is that upgrade of
XFree86 puts an empty fonts.dir file in that directory containing 0 fonts.
Presumably it runs mkfontdir instead of type1inst. Also, it does not
run mkfontdir for the misc fonts. I would understand if you would not
want to run mkfontdir/type1inst for the fonts supplied by the rpms to
avoid potential problems BUT the install/upgrade should not touch 
directories that are not part of the distribution.

How Reproducible:

Every time

Steps to Reproduce:
1. rpm -Uvh XF*.rpm
2. 
3. 

Actual Results:

Empty fonts.dir for local font directories containing Type1 fonts.

Expected Results:

Do not touch local font directories

Additional Information:
Comment 1 Mike A. Harris 2001-07-25 15:45:00 EDT
*** Bug 43562 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2002-04-20 22:22:01 EDT
XFree86 in rawhid (4.2.0) no longer creates fonts.dir in the
local directory.  However, the xfs initscript will do so if local
is in the fontpath.  Solution is making sure dirs without fonts are
not in the fontpath.  I believe that is taken care of as well in
the packaging.

Note You need to log in before you can comment on or make changes to this bug.