Bug 39804 - Build of gcc-2.96-81.src.rpm dumps core in directory /usr/include
Summary: Build of gcc-2.96-81.src.rpm dumps core in directory /usr/include
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 39806 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-09 05:17 UTC by Steve Snyder
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 19:23:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Snyder 2001-05-09 05:17:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; 0.7)
Gecko/20010503

Description of problem:
Rebuilding SRPMS gcc-2.96-81.src.rpm causes core to be dumped in directory
/usr/include.  The actual build of the binary RPMS completes aparemtly
without error.

How reproducible:
Always

Steps to Reproduce:
1.Run command "rpm --rebuild /mnt/cdrom/gcc-2.96-81.src.rpm"


Actual Results:  File "/usr/include/core" is generated

Expected Results:  No core file generated


Additional info:

The core file is generated early in the rebuild.

Comment 1 Jakub Jelinek 2001-05-09 17:43:50 UTC
*** Bug 39806 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Jelinek 2001-05-09 17:45:09 UTC
It comes from fixincl, whose "fixed" headers we don't use anyway.
I'll try to look at it, but I consider it very low priority.

Comment 3 Jakub Jelinek 2004-10-02 19:23:07 UTC
fixinc in current GCC's certainly doesn't dump core.


Note You need to log in before you can comment on or make changes to this bug.