Bug 398461 - auto-repeat leaks keystrokes to unfocused window
auto-repeat leaks keystrokes to unfocused window
Status: CLOSED DUPLICATE of bug 410561
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 12:50 EST by Alexandre Oliva
Modified: 2014-06-18 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 17:36:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2007-11-25 12:50:27 EST
Description of problem:
I have "focus follows mouse" enabled.

If I move the mouse over a window in which up and down arrows make a difference
(say karm), use Alt-TAB to switch focus to GNU Emacs, then hold up and down
arrows, some of the up and down keystroke events leak to the window under the
mouse, even though most are still delivered to GNU Emacs.

Version-Release number of selected component (if applicable):
metacity-2.21.2-1.fc9
emacs-22.1.50-1.fc9

How reproducible:
Couldn't duplicate it with focus or mouse on applications such as xchat and
pidgin, but it fails reliably with Emacs and karm.
Comment 1 Søren Sandmann Pedersen 2007-12-11 17:36:17 EST

*** This bug has been marked as a duplicate of 410561 ***

Note You need to log in before you can comment on or make changes to this bug.