Bug 410561 - X is sending repeat keystrokes to focus window and window under cursor
X is sending repeat keystrokes to focus window and window under cursor
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Adam Jackson
:
: 397231 398461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 11:22 EST by Daniel Walsh
Modified: 2008-04-05 03:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 03:22:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2007-12-04 11:22:14 EST
Description of problem:
If I hold down a key in a focus window (gnome-terminal) and have the cursor over
a different window (emacs)

The keys will show up in both windows.

For example.  If I hold the Enter key down for a long time, I will get new lines
in both the window with focus and the window under the cursor.

 rpm -qf /usr/bin/X
xorg-x11-server-Xorg-1.4.99.1-0.10.fc9

 rpm -q kernel
kernel-2.6.23.1-49.fc8
Comment 1 Matěj Cepl 2007-12-04 15:24:20 EST
*** Bug 397231 has been marked as a duplicate of this bug. ***
Comment 2 Matěj Cepl 2007-12-04 16:24:13 EST
I can reproduce this.
Comment 3 Søren Sandmann Pedersen 2007-12-11 17:36:18 EST
*** Bug 398461 has been marked as a duplicate of this bug. ***
Comment 4 Alexandre Oliva 2008-04-05 03:22:26 EDT
Seems to be fixed, even after setting the keyboard repeat rate to a very high
value.  The gnome keyboard properties that set repeat rates don't seem to be
functional, but xset still works.

Note You need to log in before you can comment on or make changes to this bug.