Bug 39857 - top shows unrealistics idle values with multithreaded programs
Summary: top shows unrealistics idle values with multithreaded programs
Status: CLOSED DUPLICATE of bug 71237
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-09 13:07 UTC by Teemu Ikonen
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-01 13:25:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Teemu Ikonen 2001-05-09 13:07:17 UTC
Description of Problem:



When running multiple Java VM's with native threads, the top command shows incorrect idle time under high load. The idle values can be as high as 80000%.



How Reproducible:



In my system, always



Steps to Reproduce:

1. Run stressfull Java programs (for example with SUN's JDK 1.3.1)

2. Start top

3. Top will evantually show incorrect idle time



Actual Results:





Expected Results:





Additional Information:

	

Kernel:

Linux cs136237.pp.htv.fi 2.4.2-2 #6 SMP Mon May 7 13:10:59 EEST 2001 i686 unknown



Machine:

1 X 450 Mhz Pentium III (Single processor system) 256MB main memory



Piece of top:

116 processes: 114 sleeping, 2 running, 0 zombie, 0 stopped

CPU states: 180.5% user,  7.1% system,  0.0% nice, 835509.0% idle

Mem:   255392K av,  253180K used,    2212K free,       0K shrd,    7008K buff

Swap:  525152K av,   11656K used,  513496K free                  124852K cached



  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND

 8191 tikonen   19   0 18612  18M  8016 R    99.9  7.2   0:06 java

 8223 tikonen    9   0 18616  18M  8016 S    70.6  7.2   0:03 java

 8216 tikonen   10   0 18612  18M  8016 S     3.5  7.2   0:00 java

 7469 tikonen   16   0  1036 1036   768 R     2.1  0.4   3:54 top

 8222 tikonen    9   0 18616  18M  8016 S     0.9  7.2   0:00 java

 8215 tikonen   19   0 18612  18M  8016 S     0.3  7.2   0:00 java

 8218 tikonen    9   0 18612  18M  8016 S     0.3  7.2   0:00 java

 8230 tikonen    9   0 18628  18M  8016 S     0.1  7.2   0:00 java

 8232 tikonen    9   0 18628  18M  8016 S     0.1  7.2   0:00 java

 8236 tikonen   14   0 18632  18M  8016 S     0.1  7.2   0:00 java

    1 root       8   0   124   72    52 S     0.0  0.0   0:09 init

    2 root       8   0     0    0     0 SW    0.0  0.0   0:00 keventd

    3 root       9   0     0    0     0 SW    0.0  0.0   0:09 kswapd

    4 root       9   0     0    0     0 SW    0.0  0.0   0:00 kreclaimd

Comment 1 Alexander Larsson 2002-08-12 09:37:03 UTC

*** This bug has been marked as a duplicate of 71237 ***


Note You need to log in before you can comment on or make changes to this bug.