Bug 71237 - incorrect idle percentage in top
incorrect idle percentage in top
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: procps (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Brian Brock
:
: 39857 76797 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-10 14:42 EDT by Ashok Kumar
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 05:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of top with incorrect idle percentage value (367.22 KB, image/png)
2002-08-10 14:44 EDT, Ashok Kumar
no flags Details

  None (edit)
Description Ashok Kumar 2002-08-10 14:42:34 EDT
Description of Problem:  Idle percentage in top utility is broken.

Version-Release number of selected component (if applicable):  top (procps
version 2.0.7)

How Reproducible: always
 
Steps to Reproduce:
1. start a cpu intensive job like compiling the kernel.
2. open top in a terminal and after it updates the display a few times,
3. the idle percentage randomly/ alternatively changes to a large positive value
over 100. 

Actual Results:   large positive value over 100. 
 
Expected Results:  value in the range 0.0 to 100.0


Additional Information:
Comment 1 Ashok Kumar 2002-08-10 14:44:25 EDT
Created attachment 69866 [details]
screen shot of top with incorrect idle percentage value
Comment 2 Alexander Larsson 2002-08-12 05:36:59 EDT
*** Bug 39857 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Larsson 2002-08-12 06:23:23 EDT
Fixed in 2.0.7-25.
Comment 4 Alexander Larsson 2002-11-05 05:01:10 EST
*** Bug 76797 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.