Bug 399101 - lua erroneously hardcodes libdir in its pkgconfig file
lua erroneously hardcodes libdir in its pkgconfig file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lua (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 436760 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 01:41 EST by Deji Akingunola
Modified: 2008-03-11 07:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 03:48:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2007-11-26 01:41:16 EST
Description of problem: lua defines 'libdir=${exec_prefix}/lib' in its pkgconfig
file, lua.pc. This causes problem detecting its library location on say x86_64
(which point to /usr/lib while the libraries are in /usr/lib64).


Version-Release number of selected component (if applicable):lua-devel-5.1.2-3.fc9


How reproducible: always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hans de Goede 2007-11-26 03:48:25 EST
Thanks for reporting this.

lua-5.1.2-4, which fixes this should show up in tomorrows rawhide push.

Since this is relatively harmless, I'm only fixing this in rawhide, let me know
if you need it fixed for some dependent package in lower Fedora versions.
Comment 2 Hans de Goede 2008-03-10 07:06:58 EDT
*** Bug 436760 has been marked as a duplicate of this bug. ***
Comment 3 Tim Niemueller 2008-03-10 08:23:54 EDT
I need this fix in Fedora 8. It's really a bad thing not to fix such trivial
bugs in older *still supported* versions as well.
Comment 4 Hans de Goede 2008-03-10 08:31:31 EDT
(In reply to comment #3)
> I need this fix in Fedora 8. It's really a bad thing not to fix such trivial
> bugs in older *still supported* versions as well.

If you can explain the _need_ part... That is explain what goes wrong other then
a few warnings, then I'm more then willing to issue an update.

People are already complaining about the number of updates, so I'm not going to
fix this just to silence a few compile time warnings.
Comment 5 Tim Niemueller 2008-03-10 08:38:40 EDT
Our test suite will report this as a bug - and in fact warnings are there for a
reason.

I think it rather annoying that if a bug has been identified it is not fixed
just to keep the update volume low. If there are bugs they demand an update, no
matter what! Especially for Lua this argument isn't worth much, the package
isn't widely used so not many machines will download it, and even if the size is
only 224 + 17 kB! Sorry, but not fixing a bug is always a bad thing.

If you do not have the time I can do it myself and push the update.
Comment 6 Hans de Goede 2008-03-11 06:24:56 EDT
(In reply to comment #5)
> Our test suite will report this as a bug - and in fact warnings are there for a
> reason.
> 

"Our test suite" still is not a very verbose explanation of why you need this
fix, and reporting harmless warnings as a bug could be considered a bug in the
test suite :) No please don't respond I agree this is a bug, the only we thing
we disagree about is the impact of it.

> I think it rather annoying that if a bug has been identified it is not fixed
> just to keep the update volume low.

There is a balance to keep between impact of the bug, and the additional
bandwith / install time consumed for end users. In this case this bug:
-only affects developers, not normal end users
-even for developers only results in a harmless warning

So I really saw, and still see no reason to issue an update, but since this
seems important for you an update to the rawhide version (which includes a jump
from 5.1.2 to 5.1.3) is on its way to updates-testing, let me know if that works
properly for you.
Comment 7 Tim Niemueller 2008-03-11 07:59:40 EDT
Works just fine, noted in pending update request.

Note You need to log in before you can comment on or make changes to this bug.