This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 436760 - Lua pkg-config file has /usr/lib as libdir on x86_64, should be /usr/lib64
Lua pkg-config file has /usr/lib as libdir on x86_64, should be /usr/lib64
Status: CLOSED DUPLICATE of bug 399101
Product: Fedora
Classification: Fedora
Component: lua (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 06:54 EDT by Tim Niemueller
Modified: 2008-03-10 07:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 07:06:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Niemueller 2008-03-10 06:54:12 EDT
Description of problem:
The pkg-config file contains an invalid library path on x86_64 systems. The line
in /usr/lib64/pkgconfig/lua.pc reads:
libdir=${exec_prefix}/lib

while in fact it should read:
libdir=${exec_prefix}/lib64

This causes warnings like
/usr/bin/ld: skipping incompatible /usr/lib/liblua.so when searching for -llua
when linking against the Lua runtime lib while using "pkg-config --libs lua".

Version-Release number of selected component (if applicable):
lua-5.1.2-1.fc8
lua-devel-5.1.2-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Create trivialmain.c with:
int main(int argc, char **argv) { return 0; }
2. Compile and link against Lua with:
gcc -o trivialmain `pkg-config --libs lua` trivialmain.c
  
Actual results:
Warnings produced since ld now search /usr/lib for *any* library.

Expected results:
No warnings, /usr/lib should not be searched on x86_64 systems.
Comment 1 Hans de Goede 2008-03-10 07:06:57 EDT
Already reported and fixed, but in rawhide only as its low impact.


*** This bug has been marked as a duplicate of 399101 ***

Note You need to log in before you can comment on or make changes to this bug.