Bug 399401 - RFE: Possibility to use additional repositories during upgrade
RFE: Possibility to use additional repositories during upgrade
Status: CLOSED DUPLICATE of bug 163299
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2007-11-26 07:37 EST by Michal Piotrowski
Modified: 2009-09-09 16:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 16:00:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Piotrowski 2007-11-26 07:37:47 EST
It would be nice to have a possibility to use additional repositories during
upgrade. I suggest that during upgrade anaconda should use repositories
configured and enabled in /etc/yum.repos.d. I think that can help eliminating
problems with upgrades on systems where a user has installed packages from
Fedora Everything which are not available on an upgrade media.

Anaconda's user interface should provide an option to enable or disable usage of
additional repositories during upgrade. It could be similar to that available in
install mode.
Comment 1 Jeremy Katz 2007-11-26 11:46:27 EST
This is something that we're hoping to enable for Fedora 9
Comment 2 George 2008-03-14 14:02:24 EDT
One extra note: anaconda doesn't care about special connections. I´m thinking
about adsl and pppoe type of internet connections that require user name and
password.
And text mode pppoe-setup (or adsl-setup) is not available at install stage eighter.
It would be nice to have the internet up and running at anaconda stage.
Comment 3 Jon Stanley 2008-04-23 16:29:09 EDT
Adding FutureFeature keyword to RFE's.
Comment 4 Paul W. Frields 2008-08-10 16:58:31 EDT
Triaged, reading repositories from /etc/yum.repos.d/ seems like something we should be able to hit for F10.

@George:  Please file a separate bug for this issue, thanks.
Comment 5 Chris Lumens 2009-09-09 16:00:57 EDT

*** This bug has been marked as a duplicate of bug 163299 ***

Note You need to log in before you can comment on or make changes to this bug.