This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 163299 - Allow specification of additional packages to install during upgrade
Allow specification of additional packages to install during upgrade
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: FutureFeature
: 248933 399401 596225 619140 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-14 17:59 EDT by Orion Poplawski
Modified: 2010-07-28 13:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 16:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-07-14 17:59:07 EDT
Description of problem:
Often when upgrading from one version of the distro to another it is desirable
to add packages that were not previously installed.  It would be helpful if you
could list in the %packages section of a kickstart file packages to add.
Comment 1 Orion Poplawski 2006-09-25 17:46:23 EDT
Still would be nice.  Moving to devel so it hopefully tracks...
Comment 2 Chris Lumens 2007-07-19 14:09:35 EDT
*** Bug 248933 has been marked as a duplicate of this bug. ***
Comment 3 John Poelstra 2008-07-07 23:47:38 EDT
triaged
Comment 4 Chris Lumens 2009-09-09 16:00:57 EDT
*** Bug 399401 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2009-09-09 16:09:37 EDT
Allowing this very quickly becomes rather complicated, though.  The natural thing to do here is to just provide the package selection interface.  Once you've done that, the problem then becomes that you might as well also provide package removal as well as package installation.  That then leads us into needing to handle both those operations in the transaction, doing all the counter-intuitive things of pulling back in packages that you explicitly unchecked, etc.
Comment 6 Chris Lumens 2010-05-26 10:35:07 EDT
*** Bug 596225 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2010-07-28 13:00:38 EDT
*** Bug 619140 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.