Bug 40004 - apacheconf crashes when add directory options
apacheconf crashes when add directory options
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apacheconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
: 41950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 23:50 EDT by redhat
Modified: 2013-04-02 00:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-10 10:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat 2001-05-09 23:50:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
when adding a directory option of a Virtual Host it crashes.


How reproducible:
Always

Steps to Reproduce:
1.start apacheconf
2. edit a virtual host
3. highligh directories
4. click add
5. click Let .htaccess files override directory options
6. click ok.
the program outputs error then hangs...


Actual Results:  Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in
__call__
    ret = apply(self.func, a)
  File "/usr/share/apacheconf/ApacheConf.py", line 870, in
on_dir_options_add_button_clicked
    run_dir_options_dialog (dialog)
  File "/usr/share/apacheconf/ApacheConf.py", line 846, in
run_dir_options_dialog
    dir_name = control.dehydrate_dir_options (dir_name)
  File "/usr/share/apacheconf/ApacheControl.py", line 760, in
dehydrate_dir_options
    dir.AllowOverride = Director.FROM_ALL
NameError: Director

Expected Results:  apacheconf should have adjusted the configuration files 
properly and not crashed.

Additional info:

since any manual change will be overwritten, this bug basically renders 
apacheconf as a useless tool.
Comment 1 Phil Knirsch 2001-05-10 10:51:23 EDT
Fixed in CVS, will be available via Rawhide soon...

Read ya, Phil
Comment 2 Phil Knirsch 2001-05-23 08:50:59 EDT
*** Bug 41950 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.