Bug 41950 - apaqche configuration tool hangs
Summary: apaqche configuration tool hangs
Status: CLOSED DUPLICATE of bug 40004
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apacheconf   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Mason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-23 03:30 UTC by Eduardo Zaborowski
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-23 03:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eduardo Zaborowski 2001-05-23 03:30:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
apacheconf is not able to save a new configuration when one chooses to
allow the .htaccess files to override the directory options.


How reproducible:
Always

Steps to Reproduce:
1. Start linuxconf
2. Choose Virtual Hosts -> Edit (or Edit Default Settings)
3. Choose Edit -> Diretories -> Edit
4. Check the .htaccess button
5. The OK and Cancel buttons do not respond anymore, window is "frozen"

Actual Results:  the OK and Cancel buttons do not respond anymore, window
is "frozen"


Expected Results:  Directory Options should have been saved

Additional info:

STDERR reads:

Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/apacheconf/ApacheConf.py", line 877, in
on_dir_options_edit_button_clicked
    run_dir_options_dialog (dialog)
  File "/usr/share/apacheconf/ApacheConf.py", line 846, in
run_dir_options_dialog
    dir_name = control.dehydrate_dir_options (dir_name)
  File "/usr/share/apacheconf/ApacheControl.py", line 760, in
dehydrate_dir_options
    dir.AllowOverride = Director.FROM_ALL
NameError: Director

Comment 1 Phil Knirsch 2001-05-23 12:51:04 UTC

*** This bug has been marked as a duplicate of 40004 ***


Note You need to log in before you can comment on or make changes to this bug.