Bug 400261 - install existed abnormally during fc8 install
install existed abnormally during fc8 install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 18:35 EST by Ray Todd Stevens
Modified: 2008-10-09 11:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 10:40:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of screen during failure (1.91 MB, image/jpeg)
2007-11-28 22:25 EST, Ray Todd Stevens
no flags Details
Picture of screen during failure (2.26 MB, image/jpeg)
2007-11-28 22:37 EST, Ray Todd Stevens
no flags Details
Picture of screen during failure (2.22 MB, image/jpeg)
2007-11-28 22:38 EST, Ray Todd Stevens
no flags Details
Picture of screen during failure (2.06 MB, image/jpeg)
2007-11-28 22:39 EST, Ray Todd Stevens
no flags Details

  None (edit)
Description Ray Todd Stevens 2007-11-26 18:35:06 EST
Description of problem:

When I try and install on a specific new machine I get a
install exited abnormally [1/1] error


Version-Release number of selected component (if applicable):

this is trying to do an over the network brand new install of fc8

It actaully works probably in fc7

How reproducible:

100%

Steps to Reproduce:
1. try and do a network install
2. get to anoconda and it crashes in a few seconds after the first line of the
program running is displayed.
3.
  
Tried to boot to rescue mode to see if I could find the problem, but it just
kind of hangs at more or less the same spot.
Comment 1 Ray Todd Stevens 2007-11-26 18:35:45 EST
By the say has anyone noticed that bugzilla still says that the current version
is fc7 ;-)
Comment 2 Jeremy Katz 2007-11-26 19:26:37 EST
Does it help if you boot with 'linux nopcmcia'?
Comment 3 Ray Todd Stevens 2007-11-27 14:37:23 EST
Well the fc7 install worked fine.
Comment 4 Ray Todd Stevens 2007-11-27 14:39:36 EST
The npcmcia didn't fix the problem with the fc8 boot.
Comment 5 Chris Lumens 2007-11-27 14:41:10 EST
Can you please attach a picture or the text of the error message to this bug report?
Comment 6 Ray Todd Stevens 2007-11-27 15:25:41 EST
The error is as I specified above "install exited abnormally [1/1]"   No other
message is given on the screen.   If I need to look somewhere else I can.
Comment 7 Ray Todd Stevens 2007-11-28 10:45:31 EST
If this is not clear enough on the error, I oculd take a digital picture of the
screen and attach it I guess.   But will the system here allow a digital picture
sized attachment.   I have had problems in the past with just large text files
being to large.
Comment 8 Ray Todd Stevens 2007-11-28 22:25:49 EST
Created attachment 272121 [details]
Picture of screen during failure
Comment 9 Ray Todd Stevens 2007-11-28 22:37:23 EST
Created attachment 272131 [details]
Picture of screen during failure
Comment 10 Ray Todd Stevens 2007-11-28 22:38:19 EST
Created attachment 272151 [details]
Picture of screen during failure
Comment 11 Ray Todd Stevens 2007-11-28 22:39:32 EST
Created attachment 272161 [details]
Picture of screen during failure
Comment 12 Ray Todd Stevens 2007-11-28 22:42:25 EST
OK here are four pictures of the screen.   One of the main screen and then a
close up of it.   The other two are the other two alt ctrl function screens.   I
hope this at least defines the error.   Let me know what else you need to know.
Comment 13 Jerry Vonau 2007-12-02 21:25:26 EST
Looks like the same bug I found, is your cpu i586 based?

https://bugzilla.redhat.com/show_bug.cgi?id=367731
Comment 14 Ray Todd Stevens 2007-12-02 22:02:07 EST
Pentium 3 600Mhz Processor

Comment 15 Ray Todd Stevens 2008-01-02 16:56:56 EST
I am fully upgraded, but I still have some old machines which do this if I need
to do a full reinstall for testing.   To do the install of this machine I did an
install of fc7 and then upgraded using yum.
Comment 16 Chris Lumens 2008-01-16 15:17:33 EST
Problems like this sometimes end up being random kernel errors that kill
anaconda and we cannot detect.  Are you able to reproduce this at all in rawhide?
Comment 17 Ray Todd Stevens 2008-01-18 00:53:02 EST
Exactly how would I do the raw hide thing?

It may be hard to actually test this, as this machine is now in production mode.
Comment 18 Jeroen van Meeuwen 2008-02-28 19:12:35 EST
Could you reproduce this using a Fedora Unity Re-Spin (it has a newer kernel)? 

http://spins.fedoraunity.org/spins to get the bits
Comment 19 Ray Todd Stevens 2008-03-01 17:51:33 EST
OK I found out how to do the rawhide thing.   Good news, bad news.

Good news  I didn't get this error.

But the bad news is that it exited before I could get to the place that the
error occurred before.   I don't know if this is a new bug or not.

I get to a place where it says 
Checking if image is a initramfs  it isn't (bad gzip magic number)   Looks like
an initrd and then just hangs.

Now this is on the machine which had this other error before.   The rawhide load
seems to be working for many other machines so far.

So is this a new error or a different display of the same error?
Comment 20 Chris Lumens 2008-09-23 10:40:46 EDT
It looks to me like your initial problem is solved by Rawhide, but you have a new issue now.  We'd need to see more details to know exactly what's going wrong but it looks like a possible bad download of the initrd or some sort of hardware failure.  I'm going to close this bug.  If you'd like to open a new one for your new issue, feel free.
Comment 21 Ray Todd Stevens 2008-10-08 10:39:08 EDT
Chris:

I am not sure if I should open another one, or if we should do something with this one.

It appears that my CPU is now too old to run fedora.  I can find this commented on a bunch of places during doing google searches.   I seem to be able to find comments on exactly my failure that mention that the older CPUs are no longer supported.   BUT

I can't find this anywhere in the official documentation.   I also find several comments specifically that there is some kind of a test of the CPU being done, and if the test fails because the CPU is not up to the task the system rebooting.  First one would think that minimum system requirements would be a matter somewhere prominent in the documentation, and I can't find it.   Also one would think that a reboot with no message in response to a test of the CPU finding that it is not up to snuff to be a really bad choice of response to a test failure.

I have a VIA c3-1 giga pro cpu.   Is my problem that this is just not enough to cut the muster?
Comment 22 Ray Todd Stevens 2008-10-08 10:41:18 EDT
Sorry about this but I do have this problem on multiple machines.   the p3 600 is now working.
Comment 23 Chris Lumens 2008-10-08 17:37:42 EDT
And you are testing this with what release?
Comment 24 Ray Todd Stevens 2008-10-08 20:29:47 EDT
I have checked this with 9, alpha through production and 10 beta.  (never got around to doing the alpha release)   I have a fairly consistent set of problems through all of them.   It works fine both for install and for operation on FC 8.
Comment 25 Chris Lumens 2008-10-09 11:06:27 EDT
I can't see how the CPU would be a problem here anyway.  If it were too old to work with Fedora, the kernel wouldn't even boot.  You wouldn't just get partway into anaconda and fail.
Comment 26 Ray Todd Stevens 2008-10-09 11:44:30 EDT
I am not sure if I am getting to anaconda or not.

You will note my comment 19.   Is this a part of anoconda or the kernel?

Could the CPU be causing this?

If it is the kernel then probably we need a new bug report, if it is still anoconda then maybe we should continue as it may be the same bug with a different expression.

Note You need to log in before you can comment on or make changes to this bug.